View Full Version : KDE Kazaa and Gnutella client for Knoppix

05-07-2004, 07:59 PM
Apollon is a native KDE file-sharing client:


Apollon uses the giFT core to connect to various networks, including OpenFT, Gnutella, FastTrack

OpenFT is the homegrown giFT network, Gnutella is the network used by BearShare, LimeWire and others and FastTrack is the popular network used by KaZaA.

It is now available for Knoppix for installation with just a klik - http://klik.berlios.de/

05-07-2004, 09:16 PM
Very nice. I was going to put this in my remaster. setting up gift was too much of a pain. Now I dont have to!

06-10-2004, 01:02 AM
I know I can use klik (and eventually I did) but first I tried the all-in-one installer (0.3 i think) ... it worked fine up until it wanted my root password, even after I created one it would not let me in.... if anyone knows why please let me know...

I'm new to linux in general and most things aren't klik happy, knoppix is great practice but I'll need to know how to install the normal way eventually.. :)

06-11-2004, 11:04 AM
klik has nothing to do with the all-in-one installer. klik will never ask you for any password or screw anything up since it all runs only in your home directory.

Btw, apollon is one of the by far most klik'd apps ever. People seem to really like it (and aMule).

06-12-2004, 01:07 AM
I like klik just fine... and I know the all-in-one installer has nothing to do with klik... but since this thread is about apollon I figured I'd try to find out if you all knew how to get around that prompt during a regular install.

06-14-2004, 08:34 PM

Sorry to bump this - and probably in the wrong forum :oops: but I have used Klik to download Apollon using a my own user account. However, although I can connect and search, when I try to download nothing happens. Files in the cue nearly all show the status "Cancelled (remotely).

When I try to download something from the gnutella or FastTrack networks, the que list disappears and giFT crashes.

I tried Apollon as root and it works a charm! Looks like a permissions thing perhaps? I have added the user account to nearly every group, but with no success.

Does anyone know how I could remedy this?I've been able to work out most noob-aspects myself, but this time I'm stumped.

Thanks and respect. Klik is a great idea!

06-15-2004, 04:26 PM
For info:

Fixed the problem by deleting all Apollon folders and re-installing.

8) Nice one

02-03-2005, 08:30 PM

Installed apollon, but it says he is missing the gift daemon... wasnt it an all in one package??

Thanks for any help!

02-05-2005, 05:25 PM
klik://apollon includes the gift daemon. Which distro are you using?


02-18-2005, 12:05 AM
I have the same problem as nvgringo. I have problems with it after kliking while on the latest kanotix (2/9/2005 i think). It appears to not set up the giftd file correctly. I have knoppix 3.4 on another partition and using klik it works just fine. I don't know what all is different except that kanotix uses 2.6.10 kernel. Either way it works great in knoppix 3.4 and can't start the deamon in kanotix 2005-1. Guess I shouldn't have switched to Kanotix, I just like the Kanotix packages and i586 optomization. Any ideas? Oh I forgot, I have removed the apollon and gift files and tried to reinstall but with no success.

02-18-2005, 04:07 PM
I've got a very rare problem :shock: with Apollon, on Knoppix v3.6 works without problems but with knoppix v3.7 I can't start gift because it'searching for libtiff.so.3 searching on my disk I found that I don't have that file but one called libtiff.so.4 :( .

Are any work aorund to make Apollon work with my distro or I 've to do apt-get gift apollon :? ?

02-20-2005, 11:10 AM
Quick and dirty fix:

ln -s /usr/lib/libtiff.so /usr/lib/libtiff.so.3

I will also fix the apollon klik installation so that this fix isn't neccessary anymore.