View Full Version : installed 3.4/recompile kernel problems

05-17-2004, 12:57 AM
Please help me. I am totally confused. I have re-installed knoppix 3.4 almost 10 times this week.

I boot knoppix 3.4 cd ..login knoppix26 noscsi. i open root and run knoppix-installer. knoppix installs fine.

now i d/l linux-2.6.5.tar.gz to /usr/src/ and untar it there.

(now for my orinoco wireless card w/monitor mode) i d/l orinoco-0.13e-dragorn-patch.diff and run patch -p1< /usr/src/linux-2.6.5/drivers/net/wireless/orinoco-0.13e-dragorn-patch.diff. ok , 4 files patched sucsessfully.

still ok.....

in /usr/src/linux-2.6.5 i do

make menuconfig
make modules modules_install

ok..after 1 1/2 hours it finishes.. i reboot.

when i choose option 2-linux-2.6.5 from lilo, it boots and i login but it will not recognize the wireless card AT ALL.

now heres what confuses me....if i reboot and choose option 1-linux-2.4.24 (or whatever the default is) it boots and i login. My POINTER does not work, and neither will a standard serial mouse.

FUNNY thing is if i tab over to root shell, i run ifconfig and my wireless shows up. Also, if i run iwpriv eth0 .... it shows the additional 'monitor' (the reults of my patching the kernel source)

Please help clarify this....

1.) why does my cursor/pointer/mouse work when i choose option 2 from lilo (linux-2.6.5) and the wireless doesnt.

2.) why does the wireless patch work under linux-2.4.24 (i understood that i patched and recompiled 2.6.5) and why DOESNT my pointer/mouse work anymore.

How many kernels does a knoppix h/d install run???? i was under the impression that it could only use 1.

Please, Please someone explain this to me. I dont want hand holding, but i am now so confused.

05-17-2004, 01:40 AM
i forgot to mention that im usinng a Dell CPxJ laptop. I dont really care which kernel i have to use as long as i can a.) use my mouse pointer and b.) get my wireless card to run with the patched drivers.


05-17-2004, 01:35 PM
Quick question - what Orinoco card do you have? I've got a silver card, and I don't need to patch or download anything to get it owrking...

05-17-2004, 01:54 PM
its a Lucent orinoco gold, but it does work. It just wont run kismet or airsnort because they require the card to be in "monitor" mode. The problem im having is getting my kernel recompiled AND recognizing all my hardware that it was previously using.

05-17-2004, 04:38 PM
:twisted: I installed Fedora Core 1 :twisted: and all my problems seem to have disapeared! :twisted:

mouse pointer works/ sound works/ xircom ethernet works/ orinoco gold w/ patched drivers works !

Thanks Fedora! :!: