View Full Version : Foriegn Language Menus

05-17-2004, 07:06 PM

I've recently installed xcdroast using apt-get which, when it ran, surplanted question marks on the menus. IE. if it had a menu that said 'File', '????' would be displayed. Likewise all dialog boxes were similarly aflicted. So if a dialog box says "Click here to erase your hard drive", it would show "???? ???? ?? ????? ???? ???? ????".

Previously I had installed gnome meeting (also from apt-get), which had a similar problem but which used a Cyrillic script for it's menus. I have never managed to get gnome meeting to work previously, so this set back was not too much of a problem: even if I had known which menu option to use, the likelyhood was that the software would remain blind and deaf from past experience. As much use as a chocolate welding torch.

Also, on one of my machines, Midnight Commander in the console has the menu options in question marks much as with xcdroast described above. "1Help 2Menu 3View 4Edit 5Copy..." are "1???? 2???? 3???? 4???? 5????..."

All of this makes learning to use Linux challenging to say the least. A bit like learning to dance blindfold.

So my question is this: Which configuration files hold the Locale information?

Are there scripts to run which configure these?

Incidently this is NOT the login console problem, that is in english as it should be.

05-25-2004, 12:39 PM

05-25-2004, 02:57 PM
If it wasn't for your mc/console problem, I'd have suspected an Xfont or gnome config problem.

What do you see when typing the following:

1) echo $LANG

2) cat /etc/environment

05-26-2004, 01:36 PM
Sorry, I thought I'd made it clear that these problems are on two different machines.

At work at the mo' (bloody windows!)

But from memory echo $LANG returns en_GB or some such. ie. not unexpected. Can't remember if I've looked at that on both.

I haven't looked at /etc/environment, will check this too.

Many thanks.

06-21-2004, 07:11 PM
This is driving me around the bend.

echo $LANG and cat /etc/environment both return en_GB.

localle-gen sorted it for a while, but the bloody question marks are back.

Is there any way I can eradicate all othe locales?