PDA

View Full Version : ISDN message HiSax load failed



bart
03-05-2003, 06:49 PM
Hi,

I got my Knoppix from PC-Welt Version 3.1
In use a Teles 16.3 ISA-card (not P&P) for my internet connection.
Works OK under Win98.
Starting ISDN-config giving all the parameters s.a. IRQ 10 IO 0xd180 and EDSS1
I filled out the provider and tried to start the connection.
At that moment a fault message tells me:
Laoding the HiSax mudule failed.

Is my CD defective or what? Can anybody give me a hint?

Thanks

rickenbacherus
03-06-2003, 09:58 PM
No your CD isn't defective. A module is a driver.

The HiSax driver differs from the older Teles driver, particularly by a practical hardware check.
When the module can't be loaded there might be a hardware problem. I would look for the following:

Check /var/log/messages for messagesd relating to HiSax.
Possible error messages you might see:

HiSax: teles 16.3 config port d80-d88 already in use

The IO port is busy. Check with cat /proc/ioports.

kernel: HiSax: couldn't get interrupt 10

That would mean that the IRQ is busy or not responding.
------->If so try another free IRQ.
The port is not detected. The card is jumpered to 180 .

When you start ISDN config try this:
IRQ 11 IO 0xd80

rickenbacherus
03-07-2003, 02:40 AM
Also check out /boot/24. <something, something> sorry I forgot the filename :shock: and see if your card is listed. I might check myself if I go back to Knoppix.

bart
03-09-2003, 08:26 PM
:wink:

OK you were right.
It turned out to be IRQ 10 and IO 0xd80. Works fine now.
Seems linux does'nt bother about hardware setting in this case.
The card was jumpered at 0xd180.

Thanks for your tip.

rickenbacherus
03-09-2003, 08:47 PM
Always glad to assist - thanks for posting back with results. Most people never bother to reply. 8)