View Full Version : Kernal panic error -- won't boot! Please help..

05-21-2004, 04:44 AM
I'm a complete newb to both linux & knoppix, but after playing around with Linspire for a while I realized that knoppix was a much better choice. I found out that the old installer script was unavailable, so I followed directions from some post to knx-hdinstall from debian.tu-bs.de.

After I ran the script (after choosing to format over my old Linspire partitions), I got no error messages, but when I actually try to boot into Linux I get a host of woes. I tried both the "Beginner" and "Debian" installation modes, with different messages but same results.

With the "Beginner" one I get just half a screen of error messages, but the one that counts (probably) is this:

initrd-tools: 0.1.67
mount: fs type devfs not supported by kernal

then finally

Kernal panic: Attempted to kill init!

And that's that--nothing more happens. When I run the "Debian" installer, I get pages upon pages of error messages, but finally ends up the same way with the same error messages that stop the process.

HELP! I had absolutely no problems running Knoppix off the CD, loved it, and all I want is a hd install. What could possibly be the problem here??? Please help!

05-21-2004, 04:51 AM
CORRECTION: I ran "knoppix-installer", apparently, and not "knx-hdinstall". Basically, I ran the latest script as fetched by the " knoppix-installer-latest-web" script on http://debian.tu-bs.de/knoppix/installer

05-21-2004, 04:02 PM
What type of Hard Drive do you have?

05-22-2004, 02:02 AM
It's an IDE laptop drive--here are the specs from System Info (WindowsXP):

Description Disk drive
Manufacturer (Standard disk drives)
Bytes/Sector 512
Media Loaded Yes
Media Type Fixed hard disk
Partitions 3
SCSI Bus 0
SCSI Logical Unit 0
SCSI Port 0
SCSI Target ID 0
Sectors/Track 63
Size 27.95 GB (30,005,821,440 bytes)
Total Cylinders 3,648
Total Sectors 58,605,120
Total Tracks 930,240
Tracks/Cylinder 255
Partition Disk #0, Partition #0
Partition Size 22.48 GB (24,132,939,264 bytes)
Partition Starting Offset 32,256 bytes
Partition Disk #0, Partition #1
Partition Size 4.98 GB (5,346,432,000 bytes)
Partition Starting Offset 24,659,389,440 bytes
Partition Disk #0, Partition #2
Partition Size 502.03 MB (526,417,920 bytes)
Partition Starting Offset 24,132,971,520 bytes

In the root terminal window, during the installation I noticed that I get two funny messages repeatedly--can't quote it verbatim right now but the first says something about how NSFT files cannot be read yet and the second says the 'ext2' file system is 'unusual' or something like that. This happens throughout the installation script.

user unknown
05-22-2004, 11:02 AM
You picked an installation - script for a 2.6 kernel, which isn't a good idea for an older kernel.
The ext2 -filesystem has no journaling, which may lead to long scandisk-runs, while ext3, reiserfs and others are much faster.

The devfs is new since kernel 2.6.

Either you get an appropriate script, or a new knoppix.

Type uname -r to find out your kernel-release, when booting from cd.

05-22-2004, 08:25 PM
Hmm... But I tried formatting the partition as ext3 as well as reiserfs with the same results. Is the problem with QTParted, maybe? Also, I tried booting with the regular "Linux" option as well as "Linux2.4" ("Linux2.6" is the third option) from LILO, all with the same results. Plus, the Knoppix I have is 3.4, dated May 17 (the latest build, I think). Does it matter that my Linux partition is named "hda3" and the swap "hda4", even though the swap comes physically before the Linux on the harddrive? Also, I don't seem to have a "hda2".

Just grasping at straws here...

user unknown
05-22-2004, 08:58 PM
What means 'tried formatting'?
Did you, and if yes, where errors reported?
If not, you formatted.

Perhaps you missed the step, to create a filesystem?


'same result': mount: fs type devfs not supported by kernal ?

If you created an extended partition, that one is normally invisible. (your hda2?)

I' don't know about problems with missorted partitions. Might be a problem, might not be. What do you mean with 'is named' - the name you pick manually for your partition? Just name it 'gregor' if you want....

Boot from cd, and see, whether you may mount the partitions.
If not, test 'mkfs'. Use Reiser or ext3, not ext2.
Then try to mount again. (No, you don't need to reboot.)

05-22-2004, 09:56 PM
By "tried formatting..." I meant I tried the installation after formatting it (without error messages) as ext3, then again as reiserfs.

What do you mean, create a filesystem? Is this a manual step that you have to do outside of the Knoppix installation procedure? Nothing during installation prompted me to make a filesystem, and there was no such option underQTparted.


Where and when do I do this? Remember, it doesn't boot, so I can't do it from within. Do I boot from CD and do it from root? If so, how do I let it know that I want to do it to the harddrive, and not to the ramdisk?

'same result': mount: fs type devfs not supported by kernal ?


What do you mean with 'is named' - the name you pick manually for your partition?

No, the name that I see when I type 'fdisk -l', as follows:

Disk /dev/hda: 30.0 GB, 30005821440 bytes
255 heads, 63 sectors/track, 3648 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hda1 * 1 2934 23567323+ 7 HPFS/NTFS
/dev/hda3 2999 3648 5221125 83 Linux
/dev/hda4 2935 2998 514080 82 Linux swap

Partition table entries are not in disk order

Perhaps related, I've tried mounting my WInXP drive from Knoppix (booted from CD), and I get an 'fs' error, as follows:

mount: wrong fs type, bad option, bad superblock on /dev/hda1,
or too many mounted file systems
(could this be the IDE device where you in fact use
ide-scsi so that sr0 or sda or so is needed?)

I will try mkfs, but as I said, i'm not sure where I do this from (I'll try root console and look for proper syntax). Thanks so much for your help; I'll post my results.

user unknown
05-22-2004, 10:20 PM
I didn't use the installation procedures partitioning, so I don't know, whether you have to do it outside.

But QTparted sound like a tool for partitioning, and not FS-creating.

To do it manually:
yes, boot from cd,
yes, as root,
and yes, from console
and yes, see for a proper syntax.
mkfs.ext3 /dev/hda3
mkswap /dev/hda4

But first make sure, you don't have scsi!

05-22-2004, 10:45 PM
You do not need to make the file system. The knoppix-installer does it all for you. There are problems with the knoppix-installer that cause it to create a 0 length initrd.img-2.6.6 file. This may have been what happened, but I have only seen this on a SCSI system.

After the hard drive install can you boot to the 2.4 kernel? I can, but when I try to boot to the 2.6 kernel I get kernel panics and this is because of the 0 length initrd.img-2.6.6 file.

I don't have a solution for this yet, but this may be your cause I am not sure

user unknown
05-23-2004, 03:13 AM
I'm not sure about the initrd, but I don't have one, and asked in another thread, what it's for (less than one month ago)
I've forgotten the answer, but you might find it by searching for 'initrd'.
Of course you have to remove the initrd - lines from your /etc/lilo.conf.

05-23-2004, 06:17 AM
I get the same kernal panic problem no matter which kernal I try to boot into (basically, I can't get a working LinuxOS going, whether it's "Linux", "Linux2.4" or "Linux2.6". The initrd thing may be something, because I get the following message when I try to run mkfs.ext3:

mkfs.ext3: Device size reported to be zero. Invalid partition specified, or
partition table wasn't reread after funning fdisk, due to
a modified partition being busy and in use. You may need to reboot
to re-read your partition table.

When I try mkfs.reiserfs, I get this:

reiserfs_create: can not create that small (0 blocks) filesystem

When I try to mount hda3, I get the same message that I got when I tried to mount WinXP, mainly
mount: wrong fs type, bad option, bad superblock on /dev/hda3

As for editing (or deleting) initrd, I can't get to it because I can't mount the drive.. :?

Should I simply start all over again with my partitions (i.e., go back into WindowsXP and use PartitionMagic, delete all partitions, and start again)? I must have tried to install this thing more than 15 times now, and it's getting really frustrating.

05-23-2004, 11:28 AM
Ok -- I've gone and re-partitioned my drive (it's now in correct order, and starts with hda2 after main), re-installed Knoppix and... still the same. It was nothing to do my partitions after all. The error message I still get is:

mount: fs type devfs not supported by kernal

I've scanned other posts and checked for bug reports, and it doesn't seem like anyone else is getting this... What could possibly be the problem!? I'm just about ready to give up, and go back to (sigh) Linspire. But I'd really like to get all the packages offered by Knoppix as well as the flexibility.. Anyone else out there with this problem???[/quote]

user unknown
05-23-2004, 06:42 PM
You had a partition of size 0 before, and now again?

You needend try to mount a filesystem, which wasn't created - of course that will fail.

fdisk /dev/hda

and report the results.

It will show partitions, size, and the filesystemtype to be used with that partition.