View Full Version : Errors during boot.

05-24-2004, 04:50 AM

I've installed Knoppix 3.4 to hard disk, and I'm getting some errors while booting.

They can be found highlighted here (http://home.coqui.net/jmfix/dmesg.txt).

Strange though, that some errors don't appear in dmesg but appear while booting. That I can remember they were modprobe related.

I have an Asus A7N8X-Deluxe mobo, 512MB RAM, GeforceFX 5200.

I did some searching, but couldn't find anything related, or perhaps I'm using the wrong search keywords?

Thank you for your help.


Take Care.

user unknown
05-24-2004, 03:51 PM
first: sending the file as rtf is oversize - plain text would have done it.
second: you could have marked, what you guess is an error.

I found the following:

Error: only one processor found.

SCSI subsystem driver Revision: 1.00
kmod: failed to exec /sbin/modprobe -s -k scsi_hostadapter, errno = 2
kmod: failed to exec /sbin/modprobe -s -k scsi_hostadapter, errno = 2

Perhaps you don't have more than one Processor?
Perhaps you don't have scsi?

05-24-2004, 05:49 PM

My apologies. I did make it into an rtf file since I had the errors highlighted in word, and at the time I had no idea how to highlight the errors in plain text.

What program did you used to read the rtf? apparently the program you used didn't interpret the highlighted text made with word 2K.

What I'm going to do is to try and highlight somehow the "errors" in plain text and paste here just the errors since they are very few.

I only have one AMD 1900+ Processor and no SCSI devices.

Thank you.

Take care.

05-24-2004, 06:39 PM
OK. I changed the dmesg to text. You can see it here (http://home.coqui.net/jmfix/dmesg.txt).

The errors are "highlighted" with a <=== at the end of the line in the text file.

The "errors", or lines that draw my attention are:

Kernel command line: BOOT_IMAGE=Linux ro root=304 ramdisk_size=100000 lang=de apm=power-off hda=scsi hdb=scsi hdc=scsi hdd=scsi hde=scsi hdf=scsi hdg=scsi hdh=scsi nomce <===it states as the language being "de" instead of "us"( any way to change that?) The hdX=scsi?

There are eight lines of ide_setup: hd(from A to H) =scsi

IO-APIC (apicid-pin) 2-0, 2-16, 2-17, 2-18, 2-19, 2-20, 2-21, 2-22, 2-23 not connected.

..MP-BIOS bug: 8254 timer not connected to IO-APIC
...trying to set up timer (IRQ0) through the 8259A ... failed.
...trying to set up timer as Virtual Wire IRQ... failed.

NFORCE2: not 100% native mode: will probe irqs later
NFORCE2: BIOS didn't set cable bits correctly. Enabling workaround.

kmod: failed to exec /sbin/modprobe -s -k scsi_hostadapter, errno = 2
kmod: failed to exec /sbin/modprobe -s -k scsi_hostadapter, errno = 2

Those are the error that appear so far in my dmesg. Some other errors appear at boot, but not in my dmesg.

Any ideas as to what can I do to resolve at least some of the errors?

Thank you.

Take care.

05-24-2004, 07:26 PM
try the noscsi and nosmp cheatcodes. worked for me with same error.when the boot: line appears just type as below

boot:knoppix noscsi nosmp

user unknown
05-24-2004, 08:52 PM
I don't know a good solution for logging the errors.
But a complicated workaround:

Doin't boot into X11, but to console (/etc/inittab: id:4:initdefault instead of id:5:...).
With Shift-PageUp you may scroll to the next page of messages.

Perhaps someone has a logfile-solution.

I don't know whether Ctrl-S (stop) and Ctrl-Q (resume) works during bootup, to stop the output. At least you may try.

05-25-2004, 07:42 AM
Thank you OErjan, I will try that. What does the nosmp cheatcode do? since I didn't find it listed on the cheatcodes table.

Thank you user unknown, I will do that, since I find a little bit cumbersome sometimes the graphical login.

Of the errors that I posted so far, I will see if using the cheat codes that OErjan suggested, doesn't give me at least some of the errors.

Kernel command line: BOOT_IMAGE=Linux ro root=304 ramdisk_size=100000 lang=de apm=power-off hda=scsi hdb=scsi hdc=scsi hdd=scsi hde=scsi hdf=scsi hdg=scsi hdh=scsi nomce

Any ideas as to why the highlighted in blue defaults to DE instead of US?

Thank you.

Take care

user unknown
05-25-2004, 02:38 PM
Perhaps the knoppix-dvd/ cd/ iso was build for german users in the first place?
Or Dr. Knopper - being a german - want's to make the german language more popular? :)

Since I allways had problems with other distros languages and german Umlauts under X11, and don't have with kn3.4, I'm comfortable with that decision :).

Perhaps most knoppix-users are germans?

05-25-2004, 05:18 PM

Thank you user unknown.

Perhaps, it could be that, since recently I've been seen more and more german sites in the Linux scene. :)

Some people say I look german, but I'm not. :lol:

I think I'm going to start learning to speak german, so I can mess with their minds. :twisted:

Thank you again.

Take care.

05-29-2004, 09:06 PM

I found the syslog, where the messages that didn't appear in dmesg.

I posted here (http://home.coqui.net/jmfix/syslog.txt) the syslog. The errors are too many to highlight, but searching for the following with the browser's find feature will be quicker.

Search for:
already loaded
timed out
no such device

Again, thank you for your help.

Take care.

user unknown
05-29-2004, 11:03 PM
You're posting bootlogs from 4 days (and very detailed)!
You expect a lot of patience from us!

Do you have a floppy inserted?
Do you know, why it tries to access the floppy?

Do you boot using 'lilo'?
If you edit /etc/lilo.conf, perhaps you find a command "append ... lang=de ..."
where you replace 'de' by 'us' or 'fr' or whatever your language of choice is.

And perhaps you make a priority list of errors, which we can try to solve step by step.

05-29-2004, 11:40 PM

Sorry I forgot to just leave the most recent boot up. I'll fix that.

Yes I do have a floppy inserted since I'm using it to boot into linux.

Yes I do use lilo, I will verify the /etc/lilo.conf

I know that things like these take time to learn and fix. All I expect from all of you is help when you can, not because you have to, but because you like to, since all of us have our day to day lives to live also. :)

Thanks again user unknown. I will make that priority list of errors.

Take care.