View Full Version : I can't find .knofig

05-28-2004, 11:43 AM
I'm triying to install Knopixx 3.4 in a Dell power Edge 700 with two discs sata and adaptec raid. I made a low level format. I booted with Knoppix cd, then i used cfdisk to made partitions.
Then, in a console, knoppix-installer, made the configuration and exit. Then i saved the configuration. Well, i run knoppix-installer again, but i got a message: ERROR check fail for HD_CHOICE(). The configuration module will now be started. I have read that i have to modify the .knofig, but i can't find it in the root directory...
Where is it?
Thank you in advance, and excuse my poor english...

05-28-2004, 01:01 PM
Hi Batustini, just go to console as root and type "kwrite /root/.knofig" without the quotation marks, of course.
That will bring up the file you want and you can look at it/edit it. I had to do the same thing when I partitioned my drive last night and was having trouble with my 3rd partition. Hope this helps you....bob

05-28-2004, 04:04 PM
first of all, thank you for your help Bob.
I've formatted the disc again. I've booted from cd. I've used qparted to make two partitions. One for swap (sda1) and another for linux (sda2) then i've rebooted. Then i've used mkswap, and mkfs.ext3 (for swap & linux), seems all be ok. Then i've gone into console: knoppix-installer-->configuration-->exit. save the congiration-->yes. It seems to be ok.
Go to a console an type: kwrite /root/.knofig, open kwrite but the file is empty (blank)...
I've tried to save configuration to a file (file called knofig), saved in /.
Then in a console: sudo kwrite knofig, open the file and modify HD_CHOICE="/dev/sda6"
Rerun knoppix-installer and i've choosed configuration from a file, i've gived the name of the file (knofig) and in this moment i am installing knoppyx to the hard disk... :lol: :lol: :lol:
Thank you very much Bob for your help...
P.S.: I hope you can understand me, and excuse my poor english again...

05-28-2004, 04:10 PM
Good.....It sure takes alot maintaining Linux!!!!! It is definitly a challenge! Its like learning the computer all over again. I had to do the same thing as you and I finally got Knoppix working OK. There are a few smaller issues I have not been able to address right now though. It is just aggravating to have to get root permission for this and that! Well good luck!

05-28-2004, 09:52 PM
I know windows deep inside, but linux... it's another GREAT world... Thank you Bob...
Best regards...

05-31-2004, 02:00 PM
It is just aggravating to have to get root permission for this and that! Well good luck!

Linux is a true multi-user system. You should be glad that not everyone has access to just anythihng on your system. Also notice that with Win you must actually log out and log back in to be comeadmin. Tell me THAT isn't a PITA! :P This is not true under *nix. I find no difficulties with it whatsoever. Are you using su?

Also you can change permissions to allow users to access what you want them to.