View Full Version : problems after HDD install

05-29-2004, 09:36 PM
i installed 3.4 to my laptop hard drive, but it ignores the fstab and won't mount /dev/hda4 where i tell it to at /home. so KDE crashes when it tries to log in, because it says it can't write anything. it also gives some errors about DCOP. if i ctrl-alt-F1 and mount /dev/hda4 at /home, it still crashes and apparently won't read from the user directory in /home. does anyone know what's wrong?

also, my touchpad does not work under 2.6.x, while it does under 2.4. so that is not too cool. and during install, there is no option to select what partitions or what kind of filesystems to use. i had to manually edit /.knofig to change to reiserfs. i also told it to use /dev/hda4 at /home in /.knofig, but apparently that didn't work, either. what happens if you don't want to install everything at /, but have separate partitions for /var, /usr, etc.? do you just have to add those to /.knofig and hope it works?

so far i am not too impressed with 3.4, it seems like a step forward from 3.3 but then 2 steps backward again. should it really be this difficult just to get a gui to load?

05-30-2004, 09:22 PM
no one knows anything? no suggestions or help at all? oh, i guess it's because i pointed out some "negatives" -- not allowed! okay, let me change my original post.

i just installed 3.4 to my laptop hard drive, and this is the greatest OS EVER!!! i have one small problem, though, in that it ignores the fstab and won't mount /dev/hda4 at /home. so KDE crashes when it tries to log in, because it says it can't write anything. it also gives some errors about DCOP. if i ctrl-alt-F1 and mount /dev/hda4 at /home, it still crashes and apparently won't read from the user directory in /home. does anyone know what's wrong?


user unknown
05-31-2004, 05:03 AM
I don't think people expect you to bootlick knoppix - most of them went here because of problems.
You didn't gave them much time, and not much information.

It seems that there are different installation-scripts available - which did you use?

What is the entry in your fstab for the /home?

I don't use automount (which is primarely mounting to /mnt/XYZN and /cdrom /cdrom1 - perhaps not mounting to /home?)
nor do I use kde, and .knofig is a perfect stranger to me :)

Left: touchpad.
Do you have three section 'Input Device' in /etc/X11/XF86Config-4, some kind of Keyboard, Mouse and Touchpad?
Probably you have Keyboard and Mouse, but not Touchpad.
Copy the Section:
Section "InputDevice"
Identifier "USB Mouse"
and modify it to

Section "InputDevice"
Identifier "Touchpad"
Driver "mouse"
Option "Protocol" "auto"
Option "ZAxisMapping" "4 5"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "true"
Option "Emulate3Timeout" "70"
Option "SendCoreEvents" "true"

and in the top-section:

Section "ServerLayout"
InputDevice "USB Mouse" "CorePointer"
InputDevice "Touchpad" "CorePointer"

Perhaps it will not work :?

(make a backup of the file before changing)

05-31-2004, 06:15 AM
Are you sure sarcasm is the way to get an answer? :roll: Anyways, how did you install? Did you use knoppix-installer and edit .knofig to tell it where to mount /home at? Or are you changing the location of /home after you've installed it? If so this (http://www.knoppix.net/docs/index.php/HomePartitionHowTo) tells how to do that.

Durand Hicks
05-31-2004, 03:11 PM
If you can, try booting the knoppix cd and then open a console as root (sudo su should be fine). Then do the following:
mount /dev/hda4 /mnt/hda4 -o rw
chroot /mnt/hda4 <--- root prompt should change since you are now in your desired home
cd / <--- change directory to root on hda4
chown -R root:staff /home <--- set permissions for all of /home
chown -R user:usergroup /home/user <--- set permissions for your user account
chown -R user1:usergroup1 /home/user1 <--- set permissions for addtional user accounts if you have any
exit <--- return to cd console
umount /mnt/hda4 <--- self-explanatory
exit <--- closes console on cd
Reboot computer and /home should work fine. KDE crashes if the regular users don't have the correct permissions for its users in their home directory.

Notes: user:usergroup is your user account and the user1 is your other user if you have multiple users besides your normal user. Root doesn't have a directory in /home.



user unknown
05-31-2004, 06:50 PM
durand: I'm not a power-chroot-er, but quiet sure, that your advise is misleading.

chroot /mnt/hda4 will make /mnt/hda4 to the actual root-dir ("/"), but I understood slackhack, that he want's /dev/hda4 to be /home.

If hda4 is used as home for a different linux-installation as well, and the UID for the users differ from that installation to knoppix, I would recommend to change the user-profiles, to use the same UID on both installations.
Otherwise he needed to repeat the 'chown' for every switching of the OS.

(man usermod, man passwd).

finally: Rebooting is allways a windows-advice.
# omit umount

should work, if it should work at all.

06-01-2004, 02:14 AM
well i reinstalled using the "beginner" profile, and now i can log in at least, though i am having a *host* of other problems. i tried installing with each of the other profiles and had the same problems, while the beginner option worked (after some adjustments).

for the record, i used the knoppix-installer script, and edited the .knofig file to mount /dev/hda4 at /home. i then saved the config as /root/.knofig, quit the installer, then started it again and loaded /root/.knofig. but that still did not change the /home directory to be /dev/hda4, so i guess it is still too experimental and has some bugs. i had to do mount the partition after booting and then reboot with it in the fstab before adding the new user account. if i added the new user after mounting but before rebooting, it wouldn't work. here is the line i am using in the fstab:
/dev/hda4 /home auto defaults,auto 1 2

the partition is reiserfs, and i had that in place of auto the first two times. i don't know if that would make a difference or not. i also had defaults,users not defaults,auto. so i don't know if one of those conditions was causing it, i'm only glad it's finally working.

the problems i'm still having are on the weird end of the spectrum, maybe mostly KDE-related, things like the keyboard keeps changing back to german after every reboot, a few programs open at boot automatically (mozilla, a konsole, and a konqueror file manager) the XF86Config problem with the touchpad remains after changing the config file a few different ways (that will probably be relatively easy to fix, however), bad fonts in mozilla, and so on. so there is a lot of work to be done, but i guess that's the way it is.

apologize for being so sarcastic. i have never used KDE before, or debian, but only slackware for a few months with fluxbox, which seems quite easy compared to this distro. i guess i was just frustrated b/c i didn't realize how different the two distros were, and it was going against my understanding to add something to the fstab and have it not work, etc. thanks for all your generous responses in light of my rudeness, i appreciate the recommendations and the link. i think since this is relatively a new install, i will try a reinstall again now that i know to use the beginner profile, and see if i can get rid of some of this kde problems. plus i would rather start from scratch at this point, because i don't remember if some of them started after upgrading with apt or were there before.


06-01-2004, 06:12 AM
I think everybody here understands frustration...no need to apologize. To be honest, I haven't messed with the latest 3.4 much...I mostly use my install of the 3.4 C't version. So I don't know which of those issues are bugs in the installer or what not. Give it another shot though.

As far as the KDE opening up programs automatically, try changing the setting in the Session Manager (click on the K, go to settings and then control panel...it's in KDE Components). Set it to "Start with an empty session" and that might prevent it from opening up any programs at startup.

06-01-2004, 10:16 AM
To be honest, I haven't messed with the latest 3.4 much...
Ditto. But doesn't a beginner-mode install rebuild its fstab on every reboot? Is there a post by FabianX somewhere which clearly states the differences between those 'modes'? If find myself hesitating more and more to answer posts related to the latest installer which I haven't used first-hand...

06-01-2004, 06:13 PM
To be honest, I haven't messed with the latest 3.4 much...
Ditto. But doesn't a beginner-mode install rebuild its fstab on every reboot?

indeed it does, and that's why i thought it worked before. there's a message during boot up that says it's rebuilding the fstab. but now with a "plain vanilla" knoppix-installer configuration (i.e., no modifications to default choices) i am getting the same problem of it not recognizing the /home mount at /dev/hda4 and failing to launch the desktop (except in root mode, of course).

it's possible that in all my installs i got confused with which was which, and the one that worked was actually not beginner mode, but one of the others. i guess i'll keep trying. i'm also going to search around to see if that script that updates the fstab can be turned off.