View Full Version : knoppix wont write lilo

05-30-2004, 02:46 PM
Hi ,

When I try to install knoppix it just wont write lilo, it says succes but doesnt show the lilo on the next startup it just starts win xp. (lilo says ok when writing)

The win xp and linux are on the samen hd (hda1), and I tried writing lilo to the mbr and the root file system. (about 80 times).

I also tried different boot managers (boot magic etc), when they try to boot linux but sometimes I get a useles grub wich I did not install or just nothing.

What is going on and how to solve this? :evil:

user unknown
05-30-2004, 03:11 PM
The win xp and linux are on the samen hd (hda1)

Both may be on the same hd: hda.
But not on the same partition: hda1.

Perhaps that's related to your problems.

Boot from cd, run 'fdisk hda', and look at the partition-list ('p'=print) to inform yourself.

05-30-2004, 05:06 PM
Dont get me wring I have installed Linux alot, The windows is hda1, Linux reiserfs (hda6), swap (hda7).

I have installed debian and debian did write the lilo boot sector:S

user unknown
05-30-2004, 06:28 PM
So is your problem solved with the debian-install, or is it just another hint?

If your problems remain:
Do you get an errormessage from lilo? What?
Can you post your lilo.conf?

05-30-2004, 09:06 PM
Debian install's correctly, and works.
But the knoppix installer also says it has correctly installed but doesnt work, it just seems to skip lilo for some reason. (the latest knoppix at the time of writing)