PDA

View Full Version : DMA problem



12-16-2002, 01:59 PM
Knoppix Users -

I used the hard-drive install script and it worked just great... now I have a problem with DMA on my hard drives... in other linux distros I have tried I had to disable DMA to have a reliable system. How do I do this in knoppix ? I notice it is possible to disable dma as a boot parameter from the LiveCD boot menu, but after install what is the solution ?

I have consulted the debian manual, but I am slightly confused about the presence of other scripts generated by the knoppix live cd in my /etc/... directory... suggestions are appreciated ..

At the moment I am using

hdparm -d0 /dev/hdX (where X is 1, or 2 in my case) to disable dma on my harddrives, if this helps others having the same problem.

Thank you.

bignick
01-05-2003, 05:08 PM
in /etc/rcS.d or /etc/rcX.d (X is your runtime level, most likely 5) you can edit one of the startup scripts by adding the command to the very end or make your own script. For example

in /etc/rc5.d create a file (S99disabledma) and put the following in it

#! /bin/bash
hdparm -d0 /dev/hdb
hdparm -d0 /dev/hdc


then change permissions so it's executable - chmod 755 should suffice