View Full Version : lilo to MBR and not showing up after knx2hd

06-16-2004, 08:45 PM
Some time ago, I already installed knoppix 3.2 on my pc. Back then I had one hd with a winxp on it and two partitions for Knoppix (Swap and linux)
I installed the knoppix without any problem and lilo configured itself ot MBR and worked fine. => I could choose which os to start while booting my pc.

Now, I have knoppix 3.4 but my pc has changed somehow. I have new mobo, new cpu and a new 160GB sata hd.
I can start knoppix fine from the cd and it recognizes all my hardware, I even see the sata disk as hde drive and my old disk as hda drive. => this looks strange because my sata disk is the one that contains my winxp and I boot from there but anyway hda or hde? what does it matter, it's there.
But ofcourse, I want to install knoppix on my pc and use lilo for dual boot system.

1) I installed knoppix at the second partition of my hda (ide) drive. It installed ok and asked me where to put lilo and I choose MBR. Install completed and the pc rebooted but I never saw lilo appearing.
I figured this might be because the hda (ide) drive is not the drive that's started first when booting. In bios I choose to boot first the sata and then the ide because the sata should be faster.
Ok, so I can't boot linux now. => removed the partition

2) I installed knoppix on a free partition at the end of the hde (sata) drive. It installed correctly and asked me again where to put lilo and again, I choose MBR.
Installation worked fine, reboot pc => no lilo.... so again, I can't boot knoppix.

Now I'm a little worried. Does the sata drive don't work with a MBR maybe? I could see the drive and it's contents when knoppix worked from the cd. Do I need some extra drivers to make it bootable from the sata drive?
Or else, is it possible to have the linux installed on the ide drive (which is not the drive that's booted from the bios) And where do I need to put that lilo so I can choose what os to start?

It's not an option for me to change the boot sequence. I want to start first the sata drive as it boots my winxp which I need for gaming.

ps: I already have a knoppix box working as my fw/rtr on an old AMD-K6II and it works great. So I'm not completely new to linux/knoppix.

Any advice will be most appreciated.


06-16-2004, 11:56 PM
Take a look at the /ec/lilo.conf
search for the line that starts with boot.
If it points to dev/hda then lilo is written on hda, but you boot on hde.

If that's the case try change the line so that it points to /dev/hde
However i don't know if lilo works with sata harddrives!

06-17-2004, 12:38 AM
Thanks for the reply.
Since I couldn't boot into linux anymore (no lilo) I tried with the resque disc that I made while installing but even that couldn't get me into linux.
So I started knoppix again from the cd and went to the lilo.conf in /mnt/hde4/etc/lilo.conf. Idd, it was written hda there but when I tried to change it, I got the msg that I couldn't write to that file even as root. :/

So I go to xp and removed the whole partition.
Then I boot again and installed the previous knoppix 3.3 instead of 3.4
3.3 was not able to make a swap partition because it had to be at least 40KB and it kept complaining while swap was 500MB! => I went on with the installation of 3.3 without swap. to hell with it, I have 1GB ram, should do the trick.
Installation went ok except for some warnings and stuff and o wonder, version 3.3 was able to install lilo to hde MBR!! I was so happy but then...
The old version was not able to detect my onboard lan cnx and I couldn't get to internet anymore (via lan to rtr/fw to cable modem) Even tough lspci showed that there was a recognized lan interface. But without internet, I can't find a driver for it ofcourse :( *cry*
No worries, (I thought) I boot again and choose windowsxp from lilo but 'the horror' I couldn't boot winxp anymore. error: could not find ntldr!!!
I'm starting to panic now but I calm down and remove lilo with "lilo -u /dev/hde" => reboot and winxp started up fine. *pfffwwww* lucky me!

So now I'm back in the old situation. Winxp works fine.
Next step: I'll install knoppix 3.4 again but this time I'll use the winxp loader as bootmanager.
Unless ofcourse somebody can help me out here. (many, many thanks in advance)

btw, I installed knoppix a few times earlier on my previous hardware configuration, on my rtr/fw box and on some other pc's but I NEVER had this kind of problems before.

Thus, I guess it's just one of those days.. :D :shock:
first I need some sleep (been awake for 20 hours now) and tomorrow is another day.


06-17-2004, 02:15 AM
Don't worry about which drive the system boots from. 3 reasons for this:

1. Sata really isn't much faster than a recent ATA drive -- not yet, anyway.
2. You'll actually boot through Lilo anyway: only XP will boot from the sata -- you'll not know the difference (in XP, anyway)
3. You probably can't get Knoppix to boot from a sata drive (yet!)

So, I'd set the bios to boot from the ATA drive and put Knoppix on that. I'd try Lilo, and if that doesn't do the job (Windows will sometimes baulk at not being on the first drive) use Grub.

06-17-2004, 08:21 AM
Thanks for your reply.

Yesterday, I was able to install knoppix 3.3 on the sata disk and even lilo was in the MBR and I could boot into it but I couldn't boot my winxp anymore due to the error: "could not find ntldr"
knoppix 3.4 didn't succeed in booting.

But as you suggest, I'll look for grub now because I don't think it's included with knoppix.

thanks and regards,