PDA

View Full Version : Knoppix hangs in boot phase, floppy LED on!



Uwe
03-11-2003, 08:23 PM
Hello,
when i start knoppix from cd, it first boots and when reaching "autoconfiguration devices", the bar increases some seconds, then the little rotating symbol doesn't move anymore. Just that moment, it seems that knoppix tries to access the floppy drive, because floppy LED light up and remain lightened!
I tried many options (failsave, noapic etc.) but nothing helps. It always hangs at the same point. Can anybody help me??

BTW: Floppy drive with Win OS is working proberly, no problems...

Thanks
Uwe

Robert Michel
03-12-2003, 12:33 AM
Salve!

Just an idea, test the CD. Use CheatCode "testcd" ad boottime.

testcd
Check CD data integrity, If your KNOPPIX CD makes strange noises during boot, or you see frequent errors like "cloop read error", or programs on your KDE desktop keep crashing randomly, then your CD image is probably defective or incomplete, or your CD-burner created a defective CD due to wrong writing speed or bad media. This is the most common error reported. Please boot with "knoppix testcd" to check if the CD is OK, and/or even better, verify the MD5 checksums that are present on the mirrors before writing the CD. Also, please read the KNOPPIX-FAQ.
(http://www.knoppix.net/docs/index.php/CheatCodes)
Greetings
rob

roadie
03-12-2003, 01:27 AM
Just curious as to what your machine is.
I had the same problem with a Compaq running a 500 Celeron while the cd ran fine on another with an AMD chip.
The only way I could get it to boot was to use a boot floppy and leave the cd tray open. On booting it would close the tray, find the cd, autoconfigure and the rest would boot fine.


Hope that helps

Uwe
03-12-2003, 09:30 PM
Hello,
i tried cheat code 'testcd', cd check result was ok. I keep on trying...

so long
Uwe

pervalidus
05-03-2003, 05:22 PM
I have the same problem if I use 'knoppix noapic'. I tried with noapic because the kernel is compiled with CONFIG_X86_UP_IOAPIC, which makes my ADSL timeout. I also tried noapic nosmp.