View Full Version : Knoppix 3.3: USB stick is not recognized

06-23-2004, 10:32 PM
Hi all,

my mainboard is an ASUS P5A-B and I have the the USB 1.1 extension slotpanel which bears the USB plug and the cable connexion to the mainboard. I wanted to see if the USB port works, so I tried it with a SONY 256 MB USB 2.0 stick.
But my Knoppix 3.3, which is installed on HDD, doesn't want to recognize it. The "KDE info centre" is not aware of any USB device. With Knoppix 3.4 (c't-version) from CD it's the same.

Any ideas what I can do that the USB port will be usable? Later on, I plan to connect a USB flatbed scanner to my PC and for now the USB stick is just to check that this port works. What shall I do?

Thanks in advance!

Kind regards,

06-24-2004, 05:07 AM
You're conflating two issues here:

1. Is the usb port recognised

2. Is the card mounted.

The output of


should give you a good idea of the first.

To mount the card you probably need to edit /etc/fstab

you'll probably find a line like:

/dev/sda1 /mnt/sda1 vfat noauto,users,exec,umask=000 0 0

with a # in front of it.

As root, edit the line to remove the #

then (still root) do

mount -a

You may need to add yourself to the usb group, too (use kuser), and do make sure that /mnt/sda1 actually exists.

07-07-2004, 01:41 PM

the situation seems to be more tricky:

1. okay, my fault: I forgot to switch on the USB support in the BIOS.
2. the USB stick is still not recognized in my Knoppix 3.3 HDD installation after adding the line given above in the file /etc/fstab. My user account was already added to that group USB, I checked it with KUser. Then I made a new link to it with a new desktop icon. But when I click on it, the filesystem won't be mounted, but an error message is shown saying that there's no block device. And strangely: In the KDE Info Centre under USB, there's no USB device shown. But lspci shows that the USB port is there. I chose /dev/sda1 for the USB and /dev/sda4 is my Iomega ZIP 100 drive (works nicely). That's the situation on HDD.
3. Starting Knoppix 3.4 from CD however, the USB stick is recognized and in the KDE Info Centre under USB you can even see its serial number and the vendor name correctly. Thus, there's probably no hardware fault. But on the desktop, all /dev/sdax (x = 1-4) icons give error messages that the filesystem could not be detected.

What can I do???

Many thanks in advance for your kind help!


07-10-2004, 01:58 PM
Hi all,

do you really want ro leave me alone with my problem mentioned above?????? No ideas??????


07-11-2004, 04:21 PM
do you have usb storage driver loaded?, try to add following lines to the /etc/modules:


note: you can also list the needed driivers for a usb device by usbmodules-command e.g.:

$ usbmodules --device /proc/bus/usb/001/005

you find the device information for each device by lsusb-command.