PDA

View Full Version : No Sound



beforewisdom
03-12-2003, 01:47 AM
Hi;

I just installed knoppix on a brand new custom built pc.

The motherboard is an Intel Desktop Board D845PESV
( also the name of the chipset )

It has onboard sound.

I ran snd config...... It said it found a sound card called:

intel corp |8280lDB AC

when I ran the sound test I got these error messages from sndconfig:

Any ideas?


===============================================
The following error occurred running the modprobe program:

/lib/modules/2.4.20-xfs/kernel/drivers/sound/i810_audio.o:
init_module: No such device
/lib/modules/2.4.20-xfs/kernel/drivers/sound/i810_audio.o:
insmod /lib/modules/2.4.20-xfs/kernel/drivers/sound/i810_audio.o
failed
/lib/modules/2.4.20-xfs/kernel/drivers/sound/i810_audio.o:
insmod sound-slot-0 failed

rickenbacherus
03-12-2003, 04:53 PM
I ran snd config...... It said it found a sound card called:

intel corp |8280lDB AC

Is that in fact the sound card that your mobo has on it?


/lib/modules/2.4.20-xfs/kernel/drivers/sound/i810_audio.o:
init_module: No such device

This tells me that it is trying to install driver 'i810audio' (because snd config told it to) but that in fact there is no device that uses this driver.


insmod /lib/modules/2.4.20-xfs/kernel/drivers/sound/i810_audio.o
failed <----of course it did
/lib/modules/2.4.20-xfs/kernel/drivers/sound/i810_audio.o:
insmod sound-slot-0 failed

It fails to insmod (install module) because nothing can use it.

I would find out what sound card is installed on your board. Then, find out which driver it uses (hopefully there is a Linux driver for it) and install or use that one.

fingers99
03-12-2003, 07:02 PM
You'll probably have to install alsa. Easy enough, but make sure you read all the documentation.

beforewisdom
03-13-2003, 02:52 AM
I ran snd config...... It said it found a sound card called:

intel corp |8280lDB AC

Is that in fact the sound card that your mobo has on it?


/lib/modules/2.4.20-xfs/kernel/drivers/sound/i810_audio.o:
init_module: No such device

This tells me that it is trying to install driver 'i810audio' (because snd config told it to) but that in fact there is no device that uses this driver.


insmod /lib/modules/2.4.20-xfs/kernel/drivers/sound/i810_audio.o
failed <----of course it did
/lib/modules/2.4.20-xfs/kernel/drivers/sound/i810_audio.o:
insmod sound-slot-0 failed

It fails to insmod (install module) because nothing can use it.

I would find out what sound card is installed on your board. Then, find out which driver it uses (hopefully there is a Linux driver for it) and install or use that one.


Sorry, I forgot to mention that I don't have a sound card......the motherboard has onboard sound.......is that supported by debian/knoppix?

rickenbacherus
03-13-2003, 03:23 AM
The term 'soundcard' is used loosely to sometimes include onboard sound as well as cards for the sake of brevity.

It's true, you do not have a removable card, none the less you have a chip that serves the same function. Find out which one it is. It is entirely possible that it has been misidentified by Linux (nothing is perfect) but if it's new it probably just needs drivers. I would follow through with fingers99's good advice of installing ALSA.

Go get a .deb :D

Where? you ask - here_. http://packages.debian.org/stable/sound/

If you need assistance getting it installed you can go here:
Debian home page www.debian.org

Once you see how easy .debs are to install you will be impressed there is also apt-get. Neither are flawless of course!

Check this out too:
http://www.google.com/linux?hl=en&lr=&ie=ISO-8859-1&q=linux+drivers