PDA

View Full Version : I cant read my windows shareI



thewalkingman
12-18-2002, 06:05 AM
I mounted my hda1 under root
but I cant read it under user
thanks

PiXeLStick
12-20-2002, 02:08 PM
I have the same problem. I have it set to automount on boot and root can browse through the fat32 drive, but the user can't. I have to unmount the drive and remount as a user to be able to use the partition while being a user.

Anyone know how to fix this?
Thanks

mag
12-20-2002, 07:18 PM
First, login as root and create a group with any name you like. For examle:
addgroup windows
Then edit your /etc/fstab as root and change your windows partition
from:
/dev/hda1 /windows vfat defaults 0 0
to:
/dev/hda1 /windows vfat defaults,gid=windows,umask=002 0 0

This change will take effect on the next reboot.
Now, you have to add user to group as for example:

adduser mag windows (I just added myself). This will work.

Please replace user name, windows partition name and group name for your case.

mag

thewalkingman
12-21-2002, 01:29 AM
:arrow: confused

are we talking about the same linux distro?


I am not
finding add users any where

PiXeLStick
12-21-2002, 02:54 AM
Thanks. I will try it and see if it works.
It is strange that it doesn't work with the generic settings though.

mag
12-21-2002, 09:25 PM
The instructions are distro independent. So if you want to find the adduser command from shell, enter "which adduser" without quotes. you should have that adduser command. Are you doing this while running from CD? Either way it should work.

The commands that you have to use are as follows:

adduser yourusername (adds user)
addgroup yourgroupname (adds group)
adduser yourusername yourgroupname (adds user to the group)

mag

thewalkingman
12-22-2002, 05:05 PM
didnt work :(



```````````````````````````````````````````````

Upon further tweaking

add a directory in /mnt named windows /mnt/windows ex.

and edit fstab to

/dev/hda1 /mnt/windows vfat defaults,gid=windows,umask=002 0 0


works!!!!


on to my next problem :)