View Full Version : Trouble with video card when using kernel 2.6

07-11-2004, 11:34 PM

I recently installed Knoppix 3.4 onto my hard drive, and so far I love it. However, whenever I try booting with kernel 2.6, my display instantly shrinks to 640x480 instead of my usual 1024x768. This problem doesn't happen when I boot with kernel 2.4.

I have a Dell Inspiron 1100 with an integrated graphics chipset by Intel. Is there any reason why my video card would work with one kernel but not the other? Thanks very much for your help.


07-12-2004, 12:02 AM
You could try running kxconfig from a root shell and manually input the settings. If you don't know what to input for settings, you may find what you need in the pdf manual. Inspiron 1100 Owner's Manual (http://support.dell.com/support/edocs/systems/ins5100/en/i1100-om.pdf)
After quitting kxconfig and saving settings, try restartx from the root shell and see what happens.

07-12-2004, 12:38 AM
Thanks for the tip. I now get the sense that my problem isn't from the video card but from the monitor. I could not find a selection for a Dell LCD screen.

Unfortunately I selected a different dell monitor and now both kernels are stuck in 640x486. On top of that, whenever I try to get back into kxconfig, the monitor starts showing a lot of horizontal and vertical lines, and I can't see what I'm doing. Is there a way to restore my kxconfig to default settings and try again? Thanks again for your help.


07-12-2004, 01:06 AM
I got kxconfig working again, but both kernels still use 640x480 resolution. I have noticed that each time I load kxconfig, the resolution is automatically adjusted to 640x480. Is there anything else I can try? Thanks.

07-12-2004, 01:42 AM
In screen resolution, use the dropdown menu to select 1024x768, refresh rate to 60 Hz and color depth to 16. I am not sure which monitor for you to select, it is a 14.1 or 15 inch active matrix TFT.

07-12-2004, 01:48 AM
You might also want to have a look at this. http://www.galis.org/doc/dell.inspiron.1100.html

edit: Check this out. http://www.knoppix.net/forum/viewtopic.php?t=11547

07-12-2004, 02:24 AM
I got kxconfig working again, but both kernels still use 640x480 resolution. I have noticed that each time I load kxconfig, the resolution is automatically adjusted to 640x480. Is there anything else I can try? Thanks.

I'm a very new to Linux and after lurking in this and other Forums, I too ventured to download and Install Knopix 3.4 as dual boot (with Win2KSP4) on an 80GB WesternDigital HDD installed on a ASUS P4V533-MX Mob [ Integrated[b] S3 Prosavage DDR K133 Video+ VIA Rhines2 Fast Ethernet Adapter + VIA VT8233 AC97 Audio and] Intel Cel 2.0 GHz processor and Compaq MV540 monitor.

I too had several display problems which required multiple troubleshoots:

1. Soon after Install, instead of booting to the KDE desktop, the screen displyed "out of range" error!

I pressed ALT+CTRL and the + of numerical key pad which started the " Voice message" the initiating setup sequence" and eventual appearnce of KDE:-)

2. Because of the 800X600 resolution chosen by default, instead of the usual 1024 X768 I used to get on Win2000, the edges of the screen were out of reach of the mouse cursor:-(

As advised by DuckDodgers earlier I clicked Knoppix> Root Shell> and typed /usr/bin/kxconfig

In the XFree86 Configuration dialog box, I choose my S3 Prosavage KM133 Video card and and and then my Compaq MV540 monitor
Clicking the Forward after Monitor selecton, gives a window to select the resolution where I chose my Windows Screen area of 1024X768; I could not get the 32 Colors but 24 bit was god enough as was the 60Hz frequency
3. But as you said the problem recurred on the next reboot!
Next time I went through the whole process as above but then returned to Knoppix> Configure>Save KNOPPIX Configuration
In the next popup I got the choice to mark the Radio button of my disk partition to save the archive.
In the next and final popup I got the instructions as to what to do at bootup.
I have not had the problem since then :-)
Hope this helps.

07-12-2004, 04:39 AM
Thanks everyone for your help. I have already updated my BIOS so that is not the problem. But I followed CMN's advice about saving the Knoppix configuration and I was able to get 1024x768 resolution back while running kernel 2.4. Thanks! Now if only I could get kernel 2.6 to work...

The main reason I wanted to get kernel 2.6 to work was because magically my microsoft wireless usb mouse worked. (By the way, I already tried modprobe -r usbmouse and modprobe hid to no avail...) Maybe someone can help me with this?

I'm still some what confused as to why my video card and monitor work with kernel 2.4 but not with kernel 2.6. Anyway, thanks again for your help.


07-12-2004, 06:07 AM
I'm glad you could reagain the ground you lost during the troubleshoot:-)

I too had the Resolution problem in both versions. I had to repeat the troubleshoot in each and luckily they got fixed in both!

I am still learning the normal structure and functions of this OS and know very little about problems and solutions.
I hope some one else more adept at this will be able to help you and I can stay on the sideline and learn:-)
Good luck.

07-13-2004, 01:59 AM
Thanks for the help everyone, I finally got it to work. I found out that after upgrading my BIOS to A30, I was able to set 8mb of my memory to the video card. I guess it was the BIOS after all!