View Full Version : Sound problems

07-12-2004, 04:12 PM
I'm having a problem with my sound - namely that there is no sound.

I've tried numerous things. When booting off the CD I have to use the alsa cheatcode. I have a hdd install now though, and I have no sound. I'm aware that this is a common problem, and that the solution is to run alsa-autoconfig. This hasn't worked for me though :(

alsa-autoconfig runs seemingly fine. It does it's thing, and completes without any errors. But still no sound :(

When I try running alsamixer I get the following error:

"alsamixer: function snd_ctl_open failed for default: no such device"

I get a similar error about this device 'default' when I go into the KDE Control Center and try and set my sound to ALSA in there.

Why is it using 'default' (and failing), and how can I change this? So far I've had no luck trying to find a solution :?

07-12-2004, 04:26 PM
Did you try going into the sound system settings and setting it to on and for hardware autodetect?

07-12-2004, 04:35 PM
Yeah I did. Turned it on - nothing happens. It is on autodetect by default. I try changing it to alsa manually, but that doesn't work either :?

07-12-2004, 07:29 PM
What about checking for drivers?

07-12-2004, 10:56 PM
I'm new to this, and I could very easily be wrong, but I was under the impression that alsa is the sound driver.

What does the 'alsa' cheatcode do when booting off the CD, that alsa-autoconfig doesn't? Whatever it is, I may not be doing it right.

07-12-2004, 11:39 PM
dont worry im knew too. But since I never had a sound problem I never investigated this stuff. I dont know much about alsa, but I do know that some companies (like via for me) provide linux drivers.

07-13-2004, 11:36 AM

Check the output of lsmod - I think you have a few "modules" that are for OSS still "lingering" - this is what my problem was... ALSA will not work unless ALL OSS modules are removed... here is an output of my "failed" lsmod -=-

cuddles@Morpheus:/proc$ lsmod
Module Size Used by
snd_via82xx 25984 0
snd_pcm 86144 1 snd_via82xx
snd_timer 25344 1 snd_pcm
snd_ac97_codec 59268 1 snd_via82xx
snd_page_alloc 13060 2 snd_via82xx,snd_pcm
gameport 8192 1 snd_via82xx
snd_mpu401_uart 10496 1 snd_via82xx
snd_rawmidi 23552 1 snd_mpu401_uart
snd_seq_device 10756 1 snd_rawmidi
snd 49540 7=20
snd_via82xx,snd_pcm,snd_timer,snd_ac97_codec,snd_m pu401_uart,snd_rawmidi,snd_seq_device
via82cxxx_audio 27912 0
uart401 13636 1 via82cxxx_audio
sound 80232 2 via82cxxx_audio,uart401
soundcore 12000 3 snd,via82cxxx_audio,sound
ac97_codec 19840 1 via82cxxx_audio

NOTE: all modules, EXCEPT for via82cxxx_audio, uart401, sound, and ac97_codec - these are still OSS modules...

What I did, locate where the OSS modules are still being loaded - mine was in /etc/modutils/aliases - a line that was something like this alias via82cxxx_audio something - I placed a # in front of it, did a update-modules, re-did a lsmod, and POOF, no more OSS modules were in the output - and my ALSA was working...

Here is the "real" output of my lsmod, after the above was done:

root@Morpheus:/etc/modutils# lsmod
Module Size Used by
snd_seq_midi 10528 0
snd_seq_oss 35840 0
snd_seq_midi_event 10624 2 snd_seq_midi,snd_seq_oss
snd_seq 54128 5 snd_seq_midi,snd_seq_oss,snd_seq_midi_event
snd_pcm_oss 51716 0
snd_mixer_oss 19072 1 snd_pcm_oss
snd_via82xx 25984 0
snd_pcm 86144 2 snd_pcm_oss,snd_via82xx
snd_timer 25344 2 snd_seq,snd_pcm
snd_ac97_codec 59268 1 snd_via82xx
snd_page_alloc 13060 2 snd_via82xx,snd_pcm
gameport 8192 1 snd_via82xx
snd_mpu401_uart 10496 1 snd_via82xx
snd_rawmidi 23552 2 snd_seq_midi,snd_mpu401_uart
snd_seq_device 10756 4 snd_seq_midi,snd_seq_oss,snd_seq,snd_rawmidi
snd 49540 13 snd_seq_midi,snd_seq_oss,snd_seq_midi_event,snd_se q,snd_pcm_oss,snd_mixer_oss,snd_via82xx,snd_pcm,sn d_timer,snd_ac97_codec,snd_mpu401_uart,snd_rawmidi ,snd_seq_device
soundcore 12000 1 snd

Now, if I can just understand how to get my OSS-emulation working...

I also had a problem (still) with alsamixer, I had to do a apt-get install of alsa again, in which case, apt-get died on trying to install alsa-base, as it has ALWAYS done for me, but a apt-get -f install resolved that...

Jez -=- you also, might want to subscribe to the following "email" ALSA list...


you can post questions, once subscribed, and you get almost twenty emails a day, on other people trying to get ALSA either working, or configured, to almost any sound card, or Linux distro... ( imaginable )

A word of caution though... If you post to this email "group", don't mention "cheat-codes", they don't understand what you will be talking about, most of the people in this "group" are running distros that are "die-hard" compile-only Linux's, I am speaking from experience here, I did once, and the flood of emails about "what the heck is a cheat-code?" came as a response... If I post, I just say something like "Debian installed 'Sid" running kernel 2.6.6", or something like that... and the version of ALSA drivers I am running...

I hope this helps,
Ms. Cuddles

07-13-2004, 02:34 PM
People keep posting outputs from lsmod here, and I'm puzzled why mine is at least three times the length of everybody elses. I guess somehow I've managed to end up with a lot of stuff getting loaded that I probably don't want/need.

Anyway, I tried commenting out the line:

alias via82cxxx via82cxxx_audio

But it doesn't seem to have made any difference.

Just now I booted from the CD (where sound works) to see if I could figure out what was done differently when booting off the CD, that might have been missed out on my hdd install. I couldn't really find anything, but then again I'm not very experienced here... But one thing I did notice is that when running off the CD, in 'Sound System', the sound system appears to be off... Yet it works... Is this unusual?

Hmm anyway, I'm still getting all these errors as if everything is trying to use a sound device called 'default', which obviously is non-existant. Why is everything using this 'default' device, and how can I make things use the proper sound device?

07-13-2004, 02:55 PM

As with a lot of things in Linux, if you work in a text readable file, that appears to be something related to what the system uses, you must also allert the system that you have changed something...

As in the case of changing something in LILO - as in the lilo.conf file, you must allert LILO that you changed something to it, thus, you run lilo from a root konsole...

As in the case of changing any modules, which in turn is "compacted" into one text read-only file, called modules.conf, you must allert the system that something has changed, so, you enter update-modules in a root konsole...

You changed the aliases file, but never notified the system that something was changed, and that it should update its files for loading...

One last thing, the output I supplied from lsmod, was editted to only "stuff" related to OSS and ALSA, mine is much longer than that...

Complete output of lsmod:

cuddles@Morpheus:~$ lsmod
Module Size Used by
ppp_deflate 8960 1
zlib_deflate 24984 1 ppp_deflate
bsd_comp 9728 0
ppp_async 14080 1
ppp_generic 29964 7 ppp_deflate,bsd_comp,ppp_async
slhc 10752 1 ppp_generic
videodev 11776 0
md5 8064 1
ipv6 248736 8
nvidia 2078568 12
lp 13768 0
ipt_state 6272 36
ipt_REJECT 9728 4
ipt_limit 6784 6
ipt_LOG 10496 6
ip_conntrack_ftp 75540 0
ip_conntrack_irc 75156 0
ip_conntrack 35588 3 ipt_state,ip_conntrack_ftp,ip_conntrack_irc
iptable_filter 6784 1
ip_tables 20240 5 ipt_state,ipt_REJECT,ipt_limit,ipt_LOG,iptable_fil ter
snd_via82xx 25984 0
snd_pcm 86144 1 snd_via82xx
snd_timer 25344 1 snd_pcm
snd_ac97_codec 59268 1 snd_via82xx
snd_page_alloc 13060 2 snd_via82xx,snd_pcm
gameport 8192 1 snd_via82xx
snd_mpu401_uart 10496 1 snd_via82xx
snd_rawmidi 23552 1 snd_mpu401_uart
snd_seq_device 10756 1 snd_rawmidi
snd 49540 7 snd_via82xx,snd_pcm,snd_timer,snd_ac97_codec,snd_m pu401_uart,snd_rawmidi,snd_seq_device
soundcore 12000 1 snd
pci_hotplug 33724 0
via_agp 9856 1
agpgart 31564 2 via_agp
tsdev 9984 0
evdev 11520 0
autofs 19456 1
parport_pc 38176 1
parport 38848 2 lp,parport_pc
8250 34448 3
serial_core 22912 1 8250
rtc 15432 0
ohci1394 33792 0
ieee1394 305296 1 ohci1394
usb_storage 66816 1
ohci_hcd 20864 0
uhci_hcd 31112 0
usbcore 94420 5 usb_storage,ohci_hcd,uhci_hcd
ide_cd 40576 0
ide_scsi 17540 2
ext3 108648 2
jbd 67488 1 ext3

When posting, it may not be necessary to completely post the whole output of something, but rather, only what pertains to the issue... Case in point, if you were having problems finding out what device name your CD-ROM was, you wouldn't post the COMPLETE output of dmesg, considering that the portion that tells which device name a hard drive, or CD-ROM, is, is pretty much near the top, and a lot of other "system" junk, most of which, would not be needed for diagnosis, is not needed, but just "noise" and waste, if it was posted...

So, try update-modules, then look in /etc/modules.conf, and I will bet that the comment line you made in the /etc/modutils/aliases file, it is not commented right now, but after the command above, it will be... Then, try your ALSA again... if it still yells, you might need to apt-get install alsa-utils again... take note that doing a apt-get install alsa-utils, MAY, want to install the alsa-base as well - in my case it did, and the alsa-base refused to install, so, I had to do a apt-get -f install to get it in completely - then my alsa worked...

Hope this helps,
Ms. Cuddles

07-13-2004, 03:57 PM
Sorry - I didn't mention it, but I actually did run update-modules after making the changes.

I also ran alsa-autoconfig again, and had another play around with the sound options in Sound System.

I've done everything you've suggested except apt-get. Or rather, I tried it but it says there is no such package. I'm guessing that means it can't find it locally. Should I have a copy locally somewhere? I have no internet access though (can't get my wifi card working in Linux), so that's a bit of a problem :/

I'm going to boot off the CD and try again to find out what it does differently.

07-15-2004, 01:37 PM
Thing is, I don't know how to distinguish between stuff that should be there and stuff that shouldn't :?.