View Full Version : Need Modem Driver

08-09-2004, 07:53 PM
I was looking for a modem driver for my "U.S. Robotics 56k Win INT" winmodem, but couldn't find any for Linux. Could someone tell me where to find one? Or how to make it work?

08-10-2004, 12:48 AM
A good resource for modems used to be:


08-10-2004, 01:05 AM
Yea, I tried that, but the scanModem wouldn't work. Do you think you could give me a decent tutorial for this?

08-10-2004, 04:44 AM
Not so much a decent tutorial, but a few starters.

First, are you running a Knoppix live cd, a hard drive installation or another Linux distro.

Second, does your OS see the modem. From a root shell type: lspci -v.

Third, try using KPPP to see if your modem can be used without additional drivers.

K -> Internet -> Connect -> KPPP under the device tab choose differentt tty's and query the modem. It might be that the thing is hanging out on a tty that isn't readily apparent. Look for AT codes being returned not just that it thinks it found a modem.

Otherwise, keep googling and use the forum search feature (next to Forum Index, not the one on the bar above) with Rockwell or some other relevent term.

In general, if you are planning to use linux for accessing the net via telephone lines, a controller based outboard modem is better.

Good luck!

08-10-2004, 04:30 PM
I'm using Knoppix 3.4 off of the cd, the OS does detect the modem, I believe, and I have already tried it many times in KPPP.

08-13-2004, 11:30 PM
I've had success using winmodem drivers from this site:


There are problems with just apt-getting the .deb package because the installation program checks for compatible gcc versions. Knoppix kernel was compiled with gcc major version 2 so the install program considers this to be incompatible & won't install.
The workaround is to download the tarball & follow the installation procedure in the readme. It consists of 3 commands, build_module, ltinst2 & autoload. The first two cause no problems but the ./autload script has the check for gcc version. Despite the dire warnings, it works just fine if you just edit the script so it doesn't do the check. Just find the if statement containing the warning 'but for safety's sake, now exiting' and comment out everything from the "if" to the "fi".