View Full Version : Network Card Problems - Help!!

03-19-2003, 06:12 PM
I'm a Knoppix newbie. I'm still learing a lot about it. I ran into trouble with my networt card. It's doesn't recognize it!! I try to install a driver for it, but there isn't any for my card. Through windows, the driver is for "HP EN1207D-TX PCI 10/100 Fast Ethernet Adapter." I was hoping there would be a generic driver, but I didn't see one. I tried a couple different ones from the list, but they didn't work either. I'm running this on an older HP machine. I'm going to be connected through DSL just for a little more info incase anyone can help me, which I hope someone can. I hope someone can help so I can learn a little more on here.

03-19-2003, 08:27 PM
Can't say for sure but when I used to use an HP NIC it used the eepro100 driver. You might try the eepro as well.

03-19-2003, 09:24 PM
Through windows, the driver is for HP EN1207D-TX PCI 10/100 Fast Ethernet Adapter
I posted on this a while back, so I'll just quote myself here:

This card uses a MX EN5038A1 chip, which (from a quick scan of Google) seems to be VERY poorly supported under ANY version of Linux. Shame on HP (even their own tech support admits it won't work under Linux). I had the same problem with an SMC TX-1211 card. You would think that brand-name hardware would "just work."

What I wound up doing was getting another network interface card (NIC). Fortunately, Knoppix LOVES the Realtek RTL8139 chip, and there are at least 2 common cards that use it: the D-Link DFE-530TX+ and the Encore ENL832-TX+. The D-Link card sells for about $12 (I got it free with my DSL kit), I bought the Encore card for $8. Both work equally well with my DSL modem and Knoppix; I would recommend them to anyone using Knoppix; it's my new "default" NIC. A bonus: the Encore drivers for Windows are newer.

Since then, I have seen other cards with this same Realtek chip for even less, and they work just as well.

03-20-2003, 07:34 AM
Thanks guys. I'm gonna try out the driver first, and if that doesn't work, I'll just pick up a new NIC. Thanks again. Anything special I shoud becareful with putting my machine on the network connected through broadband?

03-30-2003, 10:53 PM
The RTL8139 is supported for its prevalence, but the chip design has serious problems.

Personally, I go with Tulip-clone chipsets, e.g. the Linksys LNE100TX (which has used a few different chips in its lifetime; current versions are fine, archaic versions had some bugs, but are probably still 'fine' when compared to an 8139). They're all well-supported now, again due to prevalence.

This isn't to say that all Realtek chips are bad- the 8019AS (as found on many generic ISA 10baseT cards) is one of the best NE2000 clones ever made (by virtue of its integrated RAM- if you're using early 3c509s in your 486 router, trade them for generic Realteks and feel the difference!), and the 8029 is a PCI version of same that's been a great boon to alternative platforms trying to provide basic ethernet support (e.g. on the Amiga line, with recently-available PCI busboards). They just shot the food with the 8129/8139, their attempts at modern 100baseT chips.

04-04-2003, 12:42 AM
My D-Link DFE-530TX+ nic is not recognized by Knoppix 3.2. I'm on a Dell 350 mhz Optiplex.

I'm on Sympatico DSL and it's the NIC they supply.

What drivers should I try to load ?

04-04-2003, 02:45 AM
My D-Link DFE-530TX+ NIC is not recognized by Knoppix 3.2. I'm on a Dell 350 MHz Optiplex.

As im my reply above, I have no problems with this card. Found automatically, it's what I use every day. As the heading for this section states, "Please post a full output of 'lspci -v' if your hardware is not detected, and all relevant information about your hardware." It may not be being detected properly for some reason...

09-05-2003, 02:04 AM
I posted this thread over at http://www.tek-tips.com in this forum:
(can't link straight to the post I guess). The poster came back with this a bit ago:

Redhat 9 not recognizing network card

Ok a little update so you guys can help the next person that has this problem. Hewlett Packard put its name on my NIC so i thought it was a HP NIC, but i inspected the tons of number physically on the card and got the part number and found out it was made by Accton, which must have been bought out by SMC, so i used the RealTek 8139 driver.... I was beginning to think i was going ot have to get a new NIC. Thanks for you time looking though.

Don't know if it's of any help to anyone, but what the heck?