View Full Version : Instant GPRS on yr Laptop/PC

08-18-2004, 04:51 AM
Instant GPRS on yr Laptop/PC

Knoppix 3.4
USB BlueTooth Adapter
BlueTooth Device (SmartPhone/PDA)
GPRS Provider

Connect yr BT USB dongle, (I use MSI BToes)
Boot laptop/pc using Knoppix 3.4

After knoppix is up and running,
Click on the penguin Icon on the taskbar (Knoppix Root)
Network/Internet -->GPRS connection

First Knoppix will configure yr modem/CellPhone (I use Nokia6600)
Click YES;
Select bluetooth: Bluetooth wireless device (i.e cellphone/PDA)
Click OK;

Knoppix then will then Scan for your BT Device.
Click OK if it manage to detect yr BT Device
Then it will prompt a default password = 1234
Click OK;

Set this device to be yr Modem.
Click YES;

Now select your GPRS Provider
Browse to the bottom
Click other: (INIT-String)
Click OK;

Modify the GPRS Provider-String
For Celcom - change "internet" to "CELCOM" (USE UPPERCASE)
(Celcom is my GPRS Provider)
Click OK;

Then a warning regarding GPRS charges will pop-up.
Click YES;

Yr BT Device will then ask for "Passcode for Knoppix-0:"
Key-in any password
Click OK on yr BT Device

Yr Laptop/PC will then ask for a BT Pin,
Key-in the same password
Click OK;

Yr BT Device will then ask for approval to:
Accept connection request from Knoppix-0
(This step will be skipped if Knoppix-0 is already 'Set as authorised' in yr BT device)
Click YES on yr BT Device.

Your laptop/pc is connected to internet via GPRS

Download Article (http://www.fimf.net/tutorials/instant_GPRS.txt)

09-15-2004, 10:10 AM
I have a problem with laptops:
I already used the same procedure as you on different desktop-PCs with a Nokia 3650 and it did work,
but on te two laptops wich i tried (Asus L3000D and Acer TM 345T) it did not work completely: it starts correctly but after a while it hangs.
I don't think it is a problem of lcp-echo, because I commented out the two lines lcp-echo####, it seems like the problem affected the communication through the usb with the bluetooth device (chip CSR, a Roper ROBTC2-USB), and after it hangs, the GPRS connection on the phone still remains on, and if I try to restart GPRS connection, PPPD restarts, but it does not even try to re-establish the GPRS connection.
I hope you or someone else on the forum still had and solved this problem, but I did not found any solution with the search feature of the site.

10-08-2004, 08:24 PM
it starts correctly but after a while it hangs.

lcp-echo-interval 0
lcp-echo-failure 0
in your /etc/ppp/options
and it should work.