PDA

View Full Version : nVidia GeForce2 query



hugge
03-20-2003, 03:16 PM
I recently bought a nVidia GeForce2 graphics card, and wanted to test it using Knoppix, before permanently replacing my current card. I can sucessfully boot KNOPPIX_V3.1-2003-01-01-EN.iso using my current hardware.

When I installed the GeForce2 and booted, I noticed first that the audio message "initiating startup sequence" was garbled. It was as if it had been chopped up into about five pieces, and then the pieces rearranged and played back twice each. So it sounded something like this: "startu- startu- initiat- initiat- sequ- sequ- ing- ing- ence ence" (just so you get the idea, and in case someone recognizes it).

The graphics card was (as far as I can see) correctly identified, and a "vesa" driver was selected. Knoppix completed booting as usual, and all appeared to be OK, until I tried to use the mouse. The "X" was frozen in the middle of the screen and refused to move.

When I re-installed my old card (ATI Rage pro) and tried again, everything was back to normal, and the startup sound and mouse worked as usual.

I suspect some kind of interrupt problem, but I don't know where to start looking to analyse this. What further information do I need to provide so that someone can help me with this?
--
Best regards,
Peter Hugosson-Miller

rickenbacherus
03-20-2003, 09:23 PM
nvidia makes their own Linux drivers- yeah! they can be found here.

http://www.nvidia.com/content/drivers/drivers.asp

I couldn't tell you how to use them if you want to boot the Knoppix disk though - but it's easy enough to use them if you install to a hard drive. Do a search on
www.google.com/linux for 'nvidia' and you ought to get quite a bit of info. As I understand it the drivers won't compile on the new 2.5 kernel but that's just an F.Y.I. in case you upgrade kernels at some point in the future. gluck

dmiller
03-21-2003, 12:47 AM
robelanator has posted an eloquent description of how to instal Nvidia drivers
for Knoppix, posted ias HOWTO: Nvidia drivers after hard drive install in the knoppix forum hdd install section. I found it by searching the forum for
Nvidia.

very detailed, lucid, excellent thread and folllowup.

Dan

hugge
03-21-2003, 09:21 AM
Thanks, guys!

So, just to make sure I understand this:

- It is not possible to boot the Knoppix live CD into X when you have a video card that needs nVidia drivers?

- It is possible to boot into text mode, do the hdd install then fix the drivers afterwards?

- The only way to check if the card works OK is to do the install, fix the drivers and boot from the hard drive?

VeeDubb
03-21-2003, 02:31 PM
No, tha's not true. I have and nVidia GeForce 2 and knoppix looks great on the CD. It does look better with a HDinstall and the nvidia drivers though. By default a GeForce2 should use the "nv" driver, not a "vesa" driver. not sure wy your's would load that way....

hugge
03-21-2003, 04:49 PM
AHA! :D

So if I try the magic invocation "knoppix xmodule=nv" then it might work.

If this works I'll copy the exact name of the card that knoppix thinks it has detected, and maybe someone can do the relevant change to make it choose "nv" instead of "vesa" for that card.

hugge
03-26-2003, 01:05 PM
OK, as promised, here are the results of booting with the nVidia card and using the option "knoppix xmodule=nv" from the F2 screen.

Sadly it doesn't help :(, and the symptoms are as far as I can see exactly the same as before. The Startup sound is chopped up in the same way (and BTW the shutdown sound is similarly mangled), and the mouse is frozen.

Once again, putting my old video card back makes everything work again.

Anyway, back to the broken case. I used Ctrl_Alt_F1 to get back to the console, and started some analysis, saving the following files, whose names ought to be self-explanitory:



lspci.txt
lsmod.txt
dmesg.txt
fstab
modules.conf
XF86Config*


These files can be found in full here: http://www.netg.se/~hugge/archives/knoppix_nvidia_problem.bz2 in case anyone is interested in helping to track this one down.

The relevant lines from lspci are here:



00:01.0 PCI bridge: Intel Corp. 440LX/EX - 82443LX/EX AGP bridge (rev 03) (prog-if 00 [Normal decode])
Flags: bus master, 66Mhz, medium devsel, latency 64
Bus: primary=00, secondary=01, subordinate=01, sec-latency=64
Memory behind bridge: fd000000-fdffffff
Prefetchable memory behind bridge: d0000000-d7ffffff


01:00.0 VGA compatible controller: nVidia Corporation NV11 [GeForce2 MX DDR] (rev b2) (prog-if 00 [VGA])
Flags: bus master, 66Mhz, medium devsel, latency 64, IRQ 11
Memory at fd000000 (32-bit, non-prefetchable) [size=16M]
Memory at d0000000 (32-bit, prefetchable) [size=128M]
Expansion ROM at <unassigned> [disabled] [size=64K]
Capabilities: [60] Power Management version 2
Capabilities: [44] AGP version 2.0


I still reckon it's more likely to be an interrupt-related problem, as the vesa driver that knoppix selects exhibits the same symptoms as the nv driver that I selected. Of course I am not 100% sure that I used the right option, so could anyone please confirm that this


knoppix xmodule=nv

is the right thing to type at the F2 screen?

Any other ideas, anyone? Maybe the card is simply broken in a really strange way that only affects the mouse and soundcard, but I must admit it seems unlikely :).

RockMumbles
03-26-2003, 02:55 PM
try:

knoppix pci=biosirq

with and without the xmodule=nv

and see what happens, integrated chipsets seem to cause irq problems.

rock

A. Jorge Garcia
03-26-2003, 03:10 PM
Well, I have a lab for my computer science students at school with GeForce cards. KNOPPIX V3.1 (1108.2002 and 2003.0101) works fine on it.

When I try the MORPHIX-game CD, I can't even get X up and running. Apparently, MORPHIX-game is based on KNPPPIX V3.2, is there a problem in 3.2 and nv?

Regards,

Loper
03-26-2003, 03:38 PM
When I installed the GeForce2 and booted, I noticed first that the audio message "initiating startup sequence" was garbled... I suspect some kind of interrupt problem...

Is there a card in your first PCI slot? That slot shares an interrupt with the AGP slot (I'm assuming your GF2 is AGP, right?). If there is, and you have a spare slot, move it. If you have no spare slot, try swapping it with another card -- some cards "play nicer" with AGP interrupts than others. Keep in mind that PCI slots are "all the same" in one sense, but that each has a unique address and sometimes order matters. Let us know what happens...

VeeDubb
03-26-2003, 07:32 PM
I've always found that intersting about PCI's. There's been several boxes I'vebuilt where al the compnents worked fine but one prticular configuration didn't work. Amazingly, IDE drives sometimes do the same thing.

hugge
04-02-2003, 04:12 PM
Here are the results of this weeks tests!

Is seems that the original problem - that knoppix chooses an incorrect driver for my nVidia card - might not be the real issue here. It still might need fixing, I just need to figure out where to send the lspci -v output to, and it'll get fixed eventually. In my case it probably won't help, however... so this discussion should probably be moved to another forum, as it's not knoppix-specific. Maybe I'll try debian-user next.

I'll post these last results, though, in case anyone here is a PCI-interrupt guru...

The reply from "Loper" opened a real can of worms for me, as I struggled to see how the BIOS assigns interrupts to PCI cards. As he guessed, I had a card in slot "1" - my SCSI controller card. In this position it is assigned IRQ 9, and everything works fine with my ati card in place.

I thought the best way to approach this problem would be to try to find a new home for the SCSI controller, that works with the ati card, then to see if I can insert the nVidia card and have it work OK.

The detailed results are in the updated version of http://www.netg.se/~hugge/archives/knoppix_nvidia_problem.bz2 but basically, none of the other slots allow the scsi card to work usefully, as they all cause the BIOS to assign IRQ 11 to it. Interestingly, this clashes with my soundcard and stops the mouse working in exactly the same way as my original attempt with the nVidia card - the startup/shutdown sounds got chopped up in the same way, and the mouse was frozen. It is particularly interesting, as the nVidia card seems to like IRQ 11 in the one case that I have tried (with the SCSI controller in slot "1").

If anyone is interested, or would like to confirm my analysis, the contents of the archive mentioned above look like this:



knoppix_nvidia_problem/
knoppix_nvidia_problem/ati/
knoppix_nvidia_problem/ati/scsi_in_any_slot/
knoppix_nvidia_problem/ati/scsi_in_any_slot/XF86Config-4
knoppix_nvidia_problem/ati/scsi_in_slot1_working/
knoppix_nvidia_problem/ati/scsi_in_slot1_working/dmesg.txt
knoppix_nvidia_problem/ati/scsi_in_slot1_working/lspcin.txt
knoppix_nvidia_problem/ati/scsi_in_slot1_working/lspciv.txt
knoppix_nvidia_problem/ati/scsi_in_slot2/
knoppix_nvidia_problem/ati/scsi_in_slot2/dmesg.txt
knoppix_nvidia_problem/ati/scsi_in_slot2/lspcin.txt
knoppix_nvidia_problem/ati/scsi_in_slot2/lspciv.txt
knoppix_nvidia_problem/ati/scsi_in_slot3/
knoppix_nvidia_problem/ati/scsi_in_slot3/dmesg.txt
knoppix_nvidia_problem/ati/scsi_in_slot3/lspcin.txt
knoppix_nvidia_problem/ati/scsi_in_slot3/lspciv.txt
knoppix_nvidia_problem/ati/scsi_in_slot4/
knoppix_nvidia_problem/ati/scsi_in_slot4/dmesg.txt
knoppix_nvidia_problem/ati/scsi_in_slot4/lspcin.txt
knoppix_nvidia_problem/ati/scsi_in_slot4/lspciv.txt
knoppix_nvidia_problem/ati_and_nv/
knoppix_nvidia_problem/ati_and_nv/fstab
knoppix_nvidia_problem/ati_and_nv/lsmod.txt
knoppix_nvidia_problem/ati_and_nv/modules.conf
knoppix_nvidia_problem/ati_and_nv/XF86Config
knoppix_nvidia_problem/ati_and_nv/XF86Config-4.in
knoppix_nvidia_problem/ati_and_nv/XF86Config.in
knoppix_nvidia_problem/nv/
knoppix_nvidia_problem/nv/scsi_in_slot1/
knoppix_nvidia_problem/nv/scsi_in_slot1/dmesg.txt
knoppix_nvidia_problem/nv/scsi_in_slot1/lspciv.txt
knoppix_nvidia_problem/nv/scsi_in_slot1/XF86Config-4
knoppix_nvidia_problem/README


Next opportunity I get, and as long as there is still any point in doing so, I shall update this archive with test results of the nVidia card, moving the scsi controller to the other three slots.

The thing that worries me is that the nVidia card reports IRQ 11 from lspci -v, whereas the ati card doesn't report any IRQ at all. If the nVidia is so particular about which interrupt it wants to use, there may be no way to use it in my machine :(.

--
Cheers!

.~.
/V\
// \\
/( )\
^`~^
< hugge >