PDA

View Full Version : via on-board network card not supported?



tjudycki
03-21-2003, 11:36 AM
I'm trying to boot Knoppix 3.1 (downloaded January 2003), I'm using VIA EPIA V800A, at booting it says:

/lib/modules/2.4.19-xfs/kernel/drivers/net/via-rhine.o: init_module: No such device
/lib/modules/2.4.19-xfs/kernel/drivers/net/via-rhine.o: insmod /lib/modules/2.4.19-xfs/kernel/drivers/net/via-rhine.o: failed
/lib/modules/2.4.19-xfs/kernel/drivers/net/via-rhine.o: insmod via-rhine failed

Output from "lspci -v"

00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (ver 51)
Flags: bus master, medium devsel, latency 32, IRQ 15
I/O ports at e800 [size=256]
Memory at eb000000 (32-bit, non-prefetchable) [size=256]
Capabilities: <available only to root>

Anyone managed to run it?

rickenbacherus
03-21-2003, 04:39 PM
Have you seen anything of interest in /var/log/syslog?

Is that the entire output of lspci -v?

tjudycki
03-21-2003, 07:36 PM
Have you seen anything of interest in /var/log/syslog?

/var/log/syslog is empty.


Is that the entire output of lspci -v?

Of course not. I haven't retype everything as I have no floppy in that machine and no lan, so I can't easily copy lspci output - I need to write it down from the screen.

All other devices seem working and I've got no other messages.

I've just downloaded and burned CD from KNOPPIX_V3.1-2003-01-20-EN.iso - same effect.

rickenbacherus
03-21-2003, 08:03 PM
OK well we don't want you to have to write it all down but perhaps you could copy it to a hard drive, boot into your other OS and post it that way? Barring that, the output of lspci -v that you did post obviously tells us that it was unable to load the driver for your card. I suspect an IRQ conflict.

Do you see anything relevant in dmesg?

/var/log/syslog shouldn't be empty- did you view it as root?

tjudycki
03-21-2003, 08:36 PM
perhaps you could copy it to a hard drive, boot into your other OS and post it that way?

I'm doing it on a diskless machine: just VIA EPIA + CD - so it's not that easy.


Do you see anything relevant in dmesg?

No.


/var/log/syslog shouldn't be empty- did you view it as root?

Yes, I did. Otherwise I would not be able to read it. May be Knoppix save space on ramdisk by shrinking log files.

I've just passed the machine to a Linux specialist who is familiar with Knoppix. I'll let you know if he solves the problem.

tjudycki
04-03-2003, 10:28 AM
We haven't managed to solve the problem. We returned VIA and took ECS mainboard: works like a charm.

It could be a hardware problem because there was no network card in /proc/pci. A friend of mine is using the same version of Knoppix on the same model of VIA and network is working properly.

Thanks :-)

tdjokic
02-27-2005, 11:38 PM
Solution for VT6102 is acpi=off or no apm in Knoppix at boot.