View Full Version : Problem with partitions

09-05-2004, 11:58 PM
hi. I have a problem with of partitions. When i read the file /proc/partitions a vfat partition is messing (a extended). But when i run cfdisk or gtparted, the missing partition apears. How can I solve thsi?


09-06-2004, 02:51 AM
I guess I don't see what the problem is. :roll:

09-06-2004, 08:40 PM
the problem is that i can not mount the missing partition

09-06-2004, 09:00 PM
In my experience, creating the partition doesn't format it. You still need to format the partition using the mkfs command (http://www.onlamp.com/linux/cmd/cmd.csp?path=m/mkfs) in the console. I bet you'll have to do it as root, so stick "sudo" and a space in front of your mkfs command.


09-06-2004, 11:48 PM
I think this is a good post for making my question. That is:

This is my very first time i use knoppix. I'm triying to recover some files i have in one partition that win98 kicked away (I say kicked 'cos I don't really know what had win98 did to it). But I can't mount that partition.
Knoppix flag me this notice:

mount: I could not determine the filesystem type, and none was specified
Please check that the disk is entered correctly.

I'm new and I don't know whats the meaning of that and far from it the solution


09-07-2004, 01:34 AM
Hi, give us an idea of what led up to this. If it's W98, probably FAT32 fs type, or what linux calls vfat. Might try the console

Might try the console command "sudo mount -t vfat /dev/hd?? /mnt/hd??", where ?? is the location (probably a1 if it's your C: drive, or something else if it's not).


09-07-2004, 11:13 AM
I'l try to explain the real problem (it's a bit dificcult to me, I'm not english speaker)

I had a hd with 3 partitions. Twice with an OS (winxp both) and one with data.
One of the OS (c:) was running bad, so I decided to format c: and install win98 for be able to use partition magic (partition magic doesn't work properly in winxp).
I though the win98 install program let me choose in which partition i wanted to install that OS. But no.
The program restart the computer and get hanged (it does install nothing) and when i try to restart again without the cd, the pc gives me a message like: there's no OS.

That's is the problem.

How i tried to solve this?
Like i had said. I tried with knoppix and i got surprise when i see that i only have one partition in that hd and i also cant mount it.

I don't know if i have explained. Thanks lots

09-07-2004, 11:18 AM
Might try the console command "sudo mount -t vfat /dev/hd?? /mnt/hd??", where ?? is the location (probably a1 if it's your C: drive, or something else if it's not).


i have tried that command but doesn't work