View Full Version : only root can R&W NTFS & floppy

09-11-2004, 05:06 PM
I have recently jumped into the world of LiveCD Linux Distros with only minimal previous Linux knowledge. Thusly, I am having troubles with Captive-NTFS and writing to the Hard Drive under Knoppix 3.4 (5-17) with the 2.6 kernel.

First I run captive-install-acquire (I mount hda1 ro to get files) but at the end of the install it tells me that it can't find any NTFS partitions; therefore,I umount hda1, then in a terminal I do "sudo mount -t captive-ntfs -o rw /dev/hda1 /mnt/hda1" only to have it say that only root has RW permissions. I tried changing the owner through "sudo chown knoppix /mnt/hda1" but to no avail.

I checked my fstab and it seems that my hardrive is being read as auto instead of ntfs(which is probably causing the problem) but I don't know how to edit it, plus It would be a pain to have to edit it before any time I want to write files.

On another note the same thing is happening with my floppy drive ( it says that only root has permissions to rw)

I have downloaded BitDefender's LinuxDender Live! 1.5.6 and its captive ntfs works fine and I have writen many files but I like Knoppix 3.6 better and want to be able to write files. Please Help...