View Full Version : event sounds only as root

09-14-2004, 02:10 AM
all sounds work when logged in as root(log in sound, program open/close, popup dialogues, etc.....). none of these event sounds work under any of the user accounts. I'm thinking that it must be some kind of file/folder permission issue, but I have no idea how to start diagnosing and troubleshooting the problem. help me, PLEASE!!!!!


09-14-2004, 02:30 AM

This link described the fix for my problem. Love that search feature. Sorry for not using it before.

09-14-2004, 04:08 AM
Another way using arts. This is probably the 'proper' way since I'm sure KDE doesnt' rely on using an external player plus if you are using an external player such as xmms without the xmms-arts plugin, you are almost certain to get a suprise somewhere along the way because kde will start the arts daemon when it thinks it needs it and it will interfere with xmms.

1.In KDE controlcenter->enable sounds;turn on system notifications.

2.Then go to /home/user/.KDE/share/config/knotifyrc (hidden file folder...set konqueror to view hidden files) and set all three entries to true.

You should now have event sounds but maybe not sounds from websites (if using konqueror as a browser). So,

3. Go to configure konqueror->plugins->plugins; then enable 'pipe plugin sounds through arts'

You should now have sounds from websites.

Finaly, apt-get install xmms-arts, then in xmms->options->preferences set output plugin to aRTs instead of OSS.

09-26-2006, 11:26 AM
I'm having a similiar problem, all my sounds work fine when I log in as root, sounds in browser, all system sounds, mp3s... when I log back onto my user, I have all sounds EXCEPT sounds in the browser.. I've tried firefox and konqueror and still no sound in either, anybody have any suggestions?


fixed it -- not quite sure how, but i fixed it in firefox at least!