View Full Version : Knoppix 3.6 problem in booting (kernel panic)

09-16-2004, 02:38 AM
I have installed succesfully Knoppix 3.6 in /dev/hda2 using reiserfs but I receive the following errors in booting using both kernel 2.6.7 and 2.4.27:

RAMDISK: Compressed image found at block 0
VFS: mounted root (ext2 filesystem).
Freeing unused kermel memory: 264k freed
initrd-tools: 0.1.73
mount: fs type devfs not supported by kernel
umount: devfs: not mounted
VFS: Can't find ext3 filesystem on dev hda2
VFS: Can't find ext2 filesystem on dev hda2
FAT: bogus number-of-heads value
VFS: Can't find a valid FAT filesystem on dev hda2
Unable to identify CD-ROM format
ReiserFS: hda2: warning: sh-2021: reiserfs_fill_super: can not find reiserfs on hda2
FAT: bogus logical sector size 65535
VFS: Can't find a valid FAT filesystem on dev hda2
mount: fs type devfs not supported by kernel
VFS: Can't find ext3 filesystem on dev hda2
VFS: Can't find ext2 filesystem on dev hda2
FAT: bogus number-of-heads value
VFS: Can't find a valid FAT filesystem on dev hda2
umount: devfs: not mounted
pivot_root: No such file or directory
/sbin/init: 426: cannot open /dev/console: No such file
Kernel panic: Attempted to kill init!

I use the following line in grub:

root (hd0,1)
kernel /boot/vmlinuz root=/dev/hda2 ro ramdisk_size=100000 init=/etc/init lang=us apm=power-off nomce hda=1027,255,63 vga=791
initrd /boot/initrd.img

I have seen the config parameters of the kernel used in Knoppix and I see that it has not the DEVFS configuration flag activated. Is it not bad?

I use the parameter hda=1027,255,63 because Linux detects incorrectly the geometry of the hard disk. I have also booted the Knoppix CD in the installation using this parameter to avoid errors in creating the partition table. Additionally, my fstab looks as follows:

/dev/hda2 / reiserfs defaults 0 1
proc /proc proc defaults 0 0
/dev/fd0 /floppy (...)
usbdevfs /proc/bus/usb usbdevfs defaults 0 0
sysfs /sys sysfs defaults 0 0
/dev/cdrom /cdrom (...)
(...) (dvd and cdaudio)
/dev/hda1 /mnt/hda1 vfat (...)
/dev/hda3 none swap defaults 0 0

And my mtab:

proc /proc proc rw 0 0
none /proc proc rw 0 0

I use a removable IDE hard disk drive.

Any help would be very appreciated.

Thanks in advance.[/code]

10-07-2004, 09:12 PM
I'm seeing the same exact error messages you just described as well.

I have winxp and win98 on my first 2 partitions, and using partition magic8 I've installed 2 linux partitions and linux swap, installed to the root partition, not the MBR (in order to leave the windows boot menu alone).

This means I have to boot off of floppy in order to get into my new HD installation of knoppix, and when I do, LILO recognizes my linux partitions and gives me a choice, then it starts booting from the HD then I see the panic message you described.

I wonder what is necessary in order to get it to dual boot with XP/98; does linux have to be in the FIRST partition?

10-10-2004, 06:27 PM
I'm reading the same PANIC...

Could somebody pls reply with an answare?

10-11-2004, 01:11 AM
This is no solution, just another instans of the problem.
I'm also reading the same message when trying to install knoppix 3.6 on a SATA disk with the "debian" option in the knoppix-install procedure and grub as boot loader.

To begin with I used kernel 2.6.7 but did't get past one particular point in the boot process. Switching to 2.4.27 was a bit better, but it still did not make it.

I've had good experience with LILO in the past and decided that I can live without grub as my boot loader. So, after cofiguring the .knofig file to use LILO I was on it again. No luck though. It seems that it can not install knoppix with the debian option and LILO since I've, yet again, got a grub prompt after reboot :(
Is it something that I do not know or is it just not possible to use the combination debian/LILO?

I'll guess I'll try the beginner option and just edit the .knofig to use reiserfs instead of ext3.

10-12-2004, 04:20 AM
Please post back if you have any luck. I had tried the knoppix (not debian) style install, with no luck. I am sure that there exists a simple modification that would get it working.

10-14-2004, 11:21 PM
Well, I did not do exactly what I intended. First of all I should mention that I've not yet been able to install it yet.

During my install tries it looked like whenever I chose LILO, grub showed up after reebot, as mentioned before. I suspected that LILO was not "able" to override grub somehow and so to verify my suspicion I installed WinXP on the SATA drive, just to kill anything on the MBR.
After this I tried to install Knoppix 3.6, debian, with LILO but when rebooting it was not even able to read from the MBR and told me to insert something bootable.
Since then I've had a break. I will however try what I wrote about in the last post and I'll tell you how it turns out as soon as I get my motivation back :).

Another thing that has made me wonder is that, after successfull execution of the knoppix-installer there are a bunch of error messages in the terminal window that I can not make any sense out of, still the installer says that it compleated successfully! Am I the only one with these error messags? (yeah, I know that if I posted the messages it would be a lot easier for you to confirme this, but ... yeah; but what!? ;)