View Full Version : LILO will not appear after installing Knoppix

09-22-2004, 04:59 AM
here's my situation. main drive is a 120gb SATA drive, have two other IDE drives. made a 20gb partition on the main drive (i set it up as C: in windows, but shows up as hde in linux), installed Knoppix, set LILO to install to the MBR, seemed to work fine. but after rebooting, just boots straight into windows as normal, never even see the lilo screen

booted with the live cd, checked the hde2 partition where Knoppix was installed and everything looks fine there. tried dumping out to root console and installing lilo from there, but gives some errors

thought it didn't like my SATA drive, so tried installing it on one of the IDE drives, same results. also tried installing with LILO being in the root partition, no luck. yet with other distros like mandrake, lilo installs and runs just fine. any idea why with knoppix it just wont?

09-22-2004, 06:38 AM
I think knoppix is confused in making decision, whick one is your mbr. Usually it writes to hda, but this time the main hd is hde. Is there any partition recognized by knoppix as hda*x? I believed it wrote to hda.
Usually hda will be your first ide hdd.

Try changing in bios your boot order, hda becomes your first hdd boot, maybe you will see lilo.

You can install lilo to hde if you like.

or you might want to try Grub instead.

:D :D :D :D

09-22-2004, 04:01 PM
hda is my music drive. never thought about actually booting from that, though i suppose that might work. how would i force lilo to install into hde though?

and i've though about grub, but i haven't used it that much, and the only time i've tried to fool around with it i ended up fubaring my system. just need a plain jane bootloader to choose linux or windows, lilo will do that fine

user unknown
09-23-2004, 12:29 AM
Do you have in your lilo.conf:


Perhaps you may boot once by editing the bios, edit lilo.conf, rerun lilo, and rechange the bios, to boot from hde again.

09-23-2004, 12:43 AM
both Knoppix and WinXP are on the same drives, just different partitions. so how exactly would i tell the bios to boot a particular partition, and not just a drive?

user unknown
09-23-2004, 01:53 AM
1) boot from cd to console (bootparameter 3).

2) login as root.
3) mount your root-device (hda2)

mount /dev/hda2 /mnt/hda2
4) make your installation-base-root-dir the root-dir:

chroot /mnt/hda2
5) edit lilo.conf

cd /etc/
mcedit lilo.conf
now set your boot-device - I understood it is hde
6) rerun lilo

7) If no error occured exit your chroot-environment.


09-26-2004, 03:44 AM
6) rerun lilo


I'm having a similar problem to hemicuda, but I have three IDE drives: hde, hdf, and hdh (DVDRW as master on 2nd IDE cable), with the Knoppix install on hdf1. I have windows 2000 on hde1, and it boots fine, so my hde mbr is not fubar. I had previously, with 3.3, set up boot.ini to select windows or the location of the Knoppix install, at which point the LILO menu came up and offered me any drive on the computer as a boot drive (never did bother editing that out to let it just go right to 3.3), and everything was good.

When I get to the running of lilo (step 6), it gives me an error saying that it's missing a kernel module /dev/mapper/control and asks if it's not installed. :shock:

How would one fix this? I am upgrading from 3.3 to 3.6, and, although I also have a 3.4 disk and I could just put 3.4 on there, it would feel somewhat like a defeat. :oops:

I am not above putting the Linux drive first and the windows drive second, and using LILO to choos which OS to boot, so if that's a viable solution, I'll tell it in the BIOS to boot to the Linux drive instead of the windows one....


C ya,