View Full Version : J2SE-1.5???

A. Jorge Garcia
09-22-2004, 03:55 PM
OK, I just downloaded the latest Java Developers' Kit (JDK) from sun as an *.rpm. I used alien to make a *.deb. I used kpackage *.deb to install it. Of course, I did all this logged-in as root.

I followed all the directions in:


for using the *.rpm but I still only have access to the javac and java apps that came installed on KNOPPIX. Is there a missing step I need to do to get the new javac and java recognized by my users? I seem to recall someone had a similar issue last year, but I can't find that post....

BTW, I don't really need javac 1.5 or java 1.5. What I'm trying to do is get javadoc and appletviewer for my users. Also, having the javax.swing.* graphics classes available in javac would be nice....

Please help!


user unknown
09-23-2004, 12:18 AM
java doesn't need a complicated installation mechanism.

You have to set the JAVA_HOME to your java-directory, i.e.:

export JAVA_HOME=/opt/j2se in /etc/profile.
And include $JAVA_HOME/bin in your path. If your old java-app is in the path, the order who appears first is important.

export PATH=$PATH:$JAVA_HOME/bin

which javac
will show you, which javac is found first (if one at all).

A. Jorge Garcia
09-23-2004, 02:15 AM
OK, now I get it. Half the problem is that I couldn't find where the new java utilities were installed! Blackdown uses /usr/bin/ You suggest /opt/j2se/ Where it ended up is /usr/java/jdk1.5.0/ So, now, all I have to do is add /usr/java/jdk1.5.0/bin to my path in /etc/profile, right?

Well, I did that. I placed /usr/java/jdk1.5.0/bin at the end of the PATH line in /etc/profile and ran source /etc/profile. However which javac still returned /usr/bin/javac! So I placed /usr/java/jdk1.5.0/bin on the PATH in /etc/profile before /usr/bin and ran source /etc/profile. Now which javac returns /usr/java/jdk1.5.0/bin/javac, good.

New Problem: when I run any of the following:
appletviewer -version
javadoc -version
javac -version
java -version

I get this error:

Error occurred during initialization of VM
java/lang/NoClassDefFoundError: java/lang/Object

What now???

Thanx in advance,

user unknown
09-23-2004, 04:34 AM
Did you set JAVA_HOME?

Setting the /usr/java/jdk1.5.0/bin at the beginning of the path is a quick but dirty solution.

Every programm you call is firstly been searched in this directory, while most of them are in /usr/bin, usr/local/bin, /bin, /sbin /usr/sbin etc.

Probably in /usr/bin there are only a links to the blackdown-java stuff?

ls -la /usr/bin/java* should show.
Then you could delete these links.
If not, you have to choose whether you delete the files, or move them to an archive.
Before the new java works correctly, I would keep them somewhere else.

And put the $JAVA_HOME/bin at the end of the path.
You may as well make a link to the javadoc and appletviewer:

ln -s /usr/java/jdk1.5.0/bin/appletviewer /usr/local/bin/appletviewer
and similiar for javadoc
Perhaps you have the somewhat braindead /etc/alternatives installed, which is confusing:

ls /etc/alternatives
I'm not familiar with it, and have to consult the manpages for the syntax, but you then need perhaps to update-alternatives or something similar too.

update-alternatives --help
man update-alternatives

for more information.

A. Jorge Garcia
09-28-2004, 08:39 PM
Thanx for the help! I finally got it working.

It wasn't the /etc/profile stuff, it was the *.rpm! It would seem that alien couldn't handle it and the *.deb got mangled. So, I downloaded jdk-1_5_0-rc-linux-i586.bin (a self extracting installer) from http://java.sun.com/j2se/1.5.0/download.jsp instead of the *.rpm.bin and everything installed great!

Thanx again,