View Full Version : Sound Card Problems

03-23-2003, 07:39 PM
It looks like my sound card isn't recognized. Anybody know of any drivers for it? Its a Turtle Beach, but I can't figure out what model.

Henk Poley
03-23-2003, 08:03 PM
Open a console ("monitor and sea-shell"-button in KDE taskbar) and type:

lspci -v > pcidevicelist
Open the outputted file, type:

kate ./pcidevicelist
Paste the part about your soundcard here in this forum.

btw, what's the exact problem? Have you tried opening the KDE configuration center and fiddling with the sound settings ("sound and multimedia" -> "soundsystem")?

03-23-2003, 09:14 PM
02:09.0 Multimedia audio controller: Aureal Semiconductor Vortex 2 (rev fe)
Subsystem: Voyetra Technologies Montego II
Flags: bus master, medium devsel, latency 64, IRQ 9
Memory at fea80000 (32-bit, non-prefetchable) [size=256K]
I/O ports at dff0 [size=8]
I/O ports at dfe0 [size=8]
Capabilities: <available only to root>

Thanks in advance :).

03-23-2003, 09:20 PM
Ok, I got some drivers for it downloaded and instructions on how to install, but I get still get an error when I try to listen to something. The output is at the bottom. It looks like it tried to create a directory but couldn't because its a CD. Do I need to remaster Knoppix create the directories its trying to create?

Thanks again.

root@ttyp0[aureal]# make install20
make install AUCHIP=AU8820
make[1]: Entering directory `/ramdisk/home/knoppix/Desktop/sound drivers/alternative/aureal'
mv -f /etc/modules.conf /etc/modules.conf.old
gawk -f mod_conf /etc/modules.conf.old > /etc/modules.conf
echo "alias sound au8820" >> /etc/modules.conf
echo "alias midi au8820" >> /etc/modules.conf
mkdir -p /lib/modules/2.4.20-xfs/misc
mkdir: cannot create directory `/lib/modules/2.4.20-xfs/misc': Read-only file system
make[1]: *** [install] Error 1
make[1]: Leaving directory `/ramdisk/home/knoppix/Desktop/sound drivers/alternative/aureal'
make: *** [install20] Error 2

Henk Poley
03-24-2003, 10:19 AM
Hehe, I guess you should contact Knopper himself, or hope that he's reading this. From the output ("Read-only file system") it seems as you are booting from the cdrom, so I will asume that is correct.

The kernel-modules reside on the cd-rom, so you can't update that without remastering (unless you want to reinstall every time you boot the CD). And it would probably be nice if Knoppix would work out of the box for other people with the same soundcard.

If you really want it to work from the CD, and you know more about compiling, you could edit the makefiles so it won't try to put the modules in the normal location. AFAIK you can insmod (load kernel modules) from any directory.

04-01-2003, 03:51 AM
I have the exact same problem with a Turtle Beach Montego Bay card in the Dell I just acquired. Everything else works perfectly in Knoppix except sound. Did you find a solution? Maybe I'll just sway out the card with a Sound Blaster.

02-27-2005, 06:13 AM
Ok... first of all I am a total newbie, just to set the record straight.
That being said I think I have solved this one (I did for myself anyway). I have a turtle beach montego bay (vortex 1) pci sound card that came with my dell from yesteryear. Really it was quite simple to fix this problem. First I googled and found the card is based on the aureal Au8820 chipset. The subsequent turtle beach revisions Vortex2 (Au8830) (aka Turtle Beach Montego II) and Vortex Advantage (Au8810) in case your card is not the exact same as mine. My lspci output is as follows

0000:00:0e.0 Multimedia audio controller: Aureal Semiconductor Vortex 1 (rev 02)
Subsystem: Voyetra Technologies Montego
Flags: bus master, medium devsel, latency 64, IRQ 10
Memory at f5000000 (32-bit, non-prefetchable) [size=128K]
I/O ports at 1018 [size=8]
I/O ports at 1010 [size=8]

Anyway.. back to the point... After determining what chipset it was, I just followed the instructions on the alsa-project website (www.alsa-project.org) for the Aureal Au8820 sound card but I skipped all the instructions pertaining to actually INSTALLING ALSA which is allready installed in Knoppix (basically followed the instruction in the tutorial after the red text "Now insert the modules into the kernel", and I took special heed of the note where it says "Note to debian users:" since knoppix is essentially debian from what I gather). Then I went to the Control Center set everything to "auto" then went to Multimedia/sound/aumix and turned up the volume (as for some reason all levels are set to mute as default). Hope I didn't just write a bunch of stuff everyone allready knows.... I struggled with this for a while searching this same forum so I'm just puttin down what I would have liked to find.

03-03-2005, 06:15 PM
I too have an old Dell with a Turtle Beach Montego I sound card (au8820), and have sound problems. When running Knoppix live from the CD, it appears that the driver loads (identified as au8820), but no mixer can be found on the Desktop.

I am as new to Linux as a newbie can be, so I am heartened to see that there may be a solution. When I get a chance, I would like to attempt Jack's fix. Is this the alsa page you consulted for the instructions:

http://www.alsa-project.org/alsa-doc/doc-php/template.php?module=au8820 ?

Also, were you runnng live from the CD when you solved the problem?

With your help, I'm going to see if I can replicate your success. But right now, the instructions listed at the above site look Greek to me. If you can steer me in the right direction, I would appreciate it. Thanks for any help you can provide.