PDA

View Full Version : X server won't work with ATI 128 Rage video card



mag
03-24-2003, 02:32 PM
I have an ATI Rage 128 32Mb video card. I haven't been able to successfully use any of the latest Knoppix releases since the 8-11-2002 release. That release worked fine and I have it installed on my HD. However, I can use cheat code xmodule=fbdev to use the latest releases but I would like to use ATI and screen resolution 1600x1200. My monitor is capable of handling that. Has anyone had this problem and possible solution? Since it's Debian based, I have dist-upgraded mine (Knoppix 3.1)to the latest and I'm happy with it. But I'd really like to solve this problem. Any help is greatly appreciated.

mag
:)

aay
03-24-2003, 06:25 PM
Hmm. This is not much help, but you may want to see if the new experimental release with X 4.3 helps at all. My thinking is that it will clear up a lot of display problems.

mag
03-24-2003, 07:11 PM
Hmm. This is not much help, but you may want to see if the new experimental release with X 4.3 helps at all. My thinking is that it will clear up a lot of display problems.

I'll try the new experimental release. I have used the CeBit release. Let's see if the experimental one will make a difference. Thank you for your reply.

mag

ggu
05-07-2003, 09:08 AM
I have the same problem. In the november release (3.1) the X server sturts up
fine and with a good resolution. In the last releases (3.2) the screen blinks and
then the X server falls back to the vesa mode, which gives me a terrible
resolution.
Is this the fault of the XFree package?

ggu

aay
05-07-2003, 05:13 PM
I have the same problem. In the november release (3.1) the X server sturts up
fine and with a good resolution. In the last releases (3.2) the screen blinks and
then the X server falls back to the vesa mode, which gives me a terrible
resolution.
Is this the fault of the XFree package?

ggu

We need some more information here. What sort of setup do you have? What cheat codes have you tried. I've noticed in some recent posts that there is a monitor detection issue on the current version of X on Knoppix. To disable monitor detection use "knoppix nodcc" as a boot option.

rickenbacherus
05-08-2003, 03:48 AM
Did booting w/ xmodule=ati make a difference?

rickenbacherus
05-09-2003, 07:33 PM
Looks like the ATI rage needs a little something put into your XF86Config-4. Go here (http://www.justlinux.com/nhf/Hardware/Getting_Your_ATI_Rage_128_Card_Working.html)