View Full Version : Getting floppy automount to work

10-03-2004, 07:04 AM
I got floppy automount to work, but only for one user at a time, but that should easily be fixable.

Change the auto.master file to:

/mnt/auto /etc/automount.sh --timeout=3

Change automount.sh

*fat|msdos) options="${rw},uid=username,gid=username,umask=000";;
ntfs) options="ro,uid=username,gid=username,umask=0222";;

Where "username" is the name of the user you want to have access to the floppy.

I don't know if these two are required, probably not, but that's what I had when I got it working:

auto.misc has the line (comment out the other floppy line):

floppy -fstype=auto,sync,user,umask=000 :/dev/fd0

auto.mnt has instead of the original floppy line:

floppy -fstype=auto,sync,user,umask=000 :/dev/fd0

After all this, as root, do /etc/init.d/autofs restart, or reboot, and the floppy should work normally. Has anyone else had any other success with the floppy automounting?

12-18-2004, 06:25 AM
I, too, was unable to mount floppy after installing Knoppix 3.7, kernel 2.69. I made all the above
changes, but to hopefully apply to all users, I changed the suggested:

*fat|msdos) options="${rw},uid=username,gid=username,umask=000";;
ntfs) options="ro,uid=username,gid=username,umask=0222";;

where "username" is changed to the desired user, instead of "knoppix"


*fat|msdos) options="${rw},umask=000";;
ntfs) options="ro,umask=0222";;

I found this suggestion in another forum.

It seems to work. Using "users" or "user" for "username" didn't.

12-18-2004, 08:14 AM
Why do you want to auto mount the floppy anyway? Is this a hd install? You might have to create a device and delete the desktop icon. The icons that are there when first booting are usually just place holders so to say. cdrom cdrom1 and floppy anyway. They are links to nowhere. Sometimes the floppy might work, but this is uncommon after a fresh hd install. You have to create a new one by right clicking and create new device-->whatever you want-->and choose the approriate device. That works for the floppy, but when using the cdrom dvires, you have to symlink them to the device.

12-19-2004, 08:48 PM
Thanks for the reply rrfish72. I knew there had to be a better way.
Yes this was a HD install. I intend to go back before the changes I made and use your

Ish Rattan
12-29-2004, 04:32 AM
I did a hd-install of knoppix-3.7. Most of the things work except eject when used in use-mode (a user), says:
umount: /dev/cdrom mount disagrees with entry in fstab
eject: unmount of '/dev/cdrom' failed

and /etc/fstab entry for /dev/cdrom is:
/dev/cdrom /mnt/cdrom iso9660 defaults,ro,user,noexec,noauto 0 0

Any ideas?


12-29-2004, 04:55 AM
Ish Rattan, did you create the entry for the cdrom in your fstab or was it put in automatically? Either way I would change it to:

/dev/cdrom /cdrom iso9660 defaults,ro,users,noexec,noauto 0 0

Then set the symlink to

ln -sf /dev/scd0 /dev/cdrom

You also might have to create a new mount point as:

mkdir /cdrom

Though it should already be there.

Hope this helps.

Ish Rattan
12-29-2004, 03:05 PM
I changed the entry for /etc/fstab to

/dev/cdrom /cdrom iso9660 defaults,ro,users,noexec,noauto 0 0

it is the original entry (hd-install time) except for users (it was user before).

The symlink was there(and redid it just to make sure). /cdrom entry also exists.

Eject still produces the same result :
umount: /dev/cdrom mount disagrees with the fstab
eject: unmount of '/dev/cdrom' failed


12-29-2004, 04:50 PM
Try apt-get update and apt-get install eject. Are you using the mouse right click thing to eject? Does the button on the drive itself work? Does the drive work?

Ish Rattan
12-29-2004, 08:00 PM
I am not using the desktop icon but it gives a similar message.
I was trying it from command line.

The drive works (system was installed using it). As root, I can mount and
unmount it the drive (with cd in it). I shall try the apt-get route.

Thanks for help.


12-29-2004, 08:14 PM
You have to remove the cd also right, why not just press the drive eject button while you reach way way down there?

Ish Rattan
12-30-2004, 12:10 AM
The drive button was the first thing tried, has no effect.

Also, tried apt-get install eject, (after dkpg --purge eject), no change in
behavior. It (eject) does works when invoked by root user though.

Well, I gave it a try :-)

I also a message at the end of dmesg which is sort of strange:

mtrr: 0xf1000000,0x800000 overlaps existing 0xf1000000,0x200000
mtrr: 0xf1000000,0x800000 overlaps existing 0xf1000000,0x200000
(there 2 Xeon processors)

Any ideas about this one?


12-30-2004, 12:39 AM
You know then that the eject works because of the root acct. Then the new question is how to give yourself permmissions to use the application. That I don't know about, but I'm sure a post will give you the answer. Good Luck.