View Full Version : Using CUPS: client-error-not-possible

03-24-2003, 09:59 PM
Hi all,

I configured an hp710 on knoppix and worked ok, but after installing it doesn't work anymore. I configured it again after install, yet with no luck: when I send something for it to print it doesn't show any error message at all, but doesn't print either. Using the cups web interface, when I ask it to print the testpage (or re-launch a job) it shows the error "error-client-not-possible".

I have googled arouond and searched through these forums and still didn't find any solution...

I'd be grateful if someone lent me a hand on that:)

Thank you!

03-25-2003, 05:44 AM
I assume you've installed Knoppix to your hard drive. If you're using KDE you can do this:
Open the Control Center>Look & Feel>Panel>Menus. Under 'available menus" you should see 'Print System'. Highlight it, then click the >> arrow in the center to put it under 'Selected menus' then 'apply' Next click your 'start application' button (the big "K"), you should see 'Print System' from which you can easily add a printer. I found this to be much easier than the CUPS interface when adding my HP printer. KDE might be a ram hog compared to xfce, fluxbox et. al. but it sure makes things easy.

03-25-2003, 01:43 PM

Thanks for replying so soon:) However, I had had no problem at all adding the printer and it seems configured ok. I don't know which situations can cause the error i'm experiencing. I read that it may be because i'm out of quota (which can't be, i set up infinite quota) or that i am not allowed to use the printer (which i also checked, i added the user to the allowed list and checked it wasn't on the other one)

Moreover, right after installing it doesn't print the test page either. No error and no print.

03-25-2003, 01:54 PM
I don't know alot about Linux printing but I do know that I thought I had configured my printer through CUPS but it never worked until I used the KDE print configuration. Anyway......gluck

03-25-2003, 09:31 PM
IIRC, on a hd install cupsys is not being started so the CUPS daemon is not running, open a terminal window or go to a console and as root try this command:

/etc/init.d/cupsys start

see if it gives you any error messages, if not, it should now be running, so go back and try your printer again.

If your printer now works you'll need to make a link in /etc/rc5.d to startup the cups daemon, again either in a terminal or from a console as root do this:

ln -s /etc/init.d/cupsys /etc/rc5.d/S99cupsys



04-01-2003, 05:14 PM
I have had the same problem, trying to configure an HP720C in hdd-installed Knoppix V3.1 2003-01-20. (And, just like for grimborg, it worked OK "straight out of the box" when running Knoppix from the CD).
For the next step, after those given so far in the thread, I copied the configuration file from
/etc/ppa/pnm2ppa.conf.hp720 to /etc/pnm2ppa.conf
and now it works.
(The system had produced a choice of 3 configuration files in /etc/ppa/ , namely
pnm2ppa.conf.hp720 (contains line "version 720 # 710, 712, 722 also acceptable")
pnm2ppa.conf.hp820 ,
depending on your hardware you might want to un-comment and 'tune' the defaults).

04-01-2003, 10:32 PM
Just before I read that last reply i changed the sources.conf to get the testing/unstable packages and did an apt-get upgrade and surprisingly the printer worked:)

Thank you all for your replies! :lol:


04-01-2003, 11:22 PM
Thanks for taking the time to post your solution grimborg.