View Full Version : Yet another login problem

10-19-2004, 04:55 PM
I've been using windows for a long time and pretty new for linux. However, I was so impressed by a Knoppix demo the passing Saturday, I decided to try a HD install on Monday and had a problem. Here is how I install it:

1) I have a 40GB HD. The first 20GB (NTFS) is for win2k, another 10GB is FAT32, and 10GB for linux (750M swap, remaining ext3).

2) I searched this site and decide to go for a HD install, so I chose debian-style and let Lilo write to MSR. Everything is fine works, but I just can't access internet and plug in my usb thumbdrive, and it's totally different from the Knoppix live CD, there I can have all the setup ready automatically.

3) Thought I'm pretty new to linux, so I decided to go back Knoppix-style, and I format the linux space, and reinstall Knoppix and chose Knoppix-style this time. Everything is perfect and here came the problem.

4) Since I found everytime I boot computer, Knoppix doesn't ask me any password, and it's secure, I searched the forum and decided to follow shah's instruction listed below:

Check and Test:
(1) Check your /etc/init.d, make sure there is kdm script in there.
--Yes, I have kdm script there.
(2) Check if KDM is install, run : locate kdm
--Looks yes, after I type this command, a lot stuff come out.
(3) Check your /etc/inittab, is there a line on top:
id:5:initdefault: ..............to make sure you run on appropriate
--Yes, there is a line
(4)Get out from Xsession : ctrl+alt+backspace
--No problem
(5) As root, run this command /etc/init.d/kdm start
If you can see the login screen and able to login, proceed to editing
--Not sure if this step is correct or not. I did setup a password
for root. When I hit this command, nothing happened, no
error message shown, but just reture to cursor.

(1) Edit your /etc/rc5.d
(a)remove symlink of S*xsession or move in to any backup folder
(to be save). S*xsession is a script which let you boot directly to
kde. -- I don't have S*xsession in /etc/rc5.d, only S20cypsys,
But I did temporarily move it into another folder.
(b)Create a new symlink to /etc/init.d/kdm
root konsole:update-rc.d kdm start 90 5.
--I forgot the exact command I typied, similar to this, which
results in adding a K20kdm link to each folder from rc0.d ~
(2) Shutdown/reboot
(3) If something goes wrong after reboot and you can't enter xsession,
restore S*xsession and remove kdm in /etc/rc5.d using mc.
--My problem is, after reboot, it does show login window, but
when I type root and password, it just goes back to the login
window again! I can't enter anymore.

Who knows how can I login again (yes I can login with live cd, but I just can't modify anything, even I check out the read only box) and how can I setup a secure login correctly?

A little long, but I just hope some guru can help me with as much as info I provided.

Thanks in advance.

10-21-2004, 04:44 AM
You didn't replace kdm-np in etc/pam.d/kdm-np.
The url I gave last time doesn't work anymore.
This is the kdm-np looks like:

# /etc/pam.d/kdm - specify the PAM behaviour of kdm

# The standard Unix authentication modules, used with
# NIS (man nsswitch) as well as normal /etc/passwd and
# /etc/shadow entries.
# Remove include common-auth line for no password logins
#@include common-auth
@include common-account
@include common-password
@include common-session

auth required pam_nologin.so
auth required pam_env.so
session required pam_limits.so

auth required pam_permit.so

If above doesn't work
Try delete this :
then reboot.

If still doesn't work, go for GDM.

Still doesn't work...Go for debian like installation. Less problematic.

Still doesn't work.... Go for Kanotix.
:D :D :D