View Full Version : Cannot start application from desktop (hdd-install)

10-29-2004, 03:21 PM

I have installed knoppix to my laptop. I have downloaded and installed several programms like firefox and thunderbird. They do start perfectly, if I start them from the console. When I use a link on the desktop, nothing happens. It's a matter of rights. I have set all rights to 777 without any result. Where are 'hidden' rights, that I have not run across yet, that prevent the start. Same if I want to make a link to for example 'mc'. If I right-klick a programm in the menu and move it to the desktop, I can start it without problems.

Any hints


10-30-2004, 03:53 AM
How are you making the Desktop links?
I have just tried creating a link by the simplest possible method: Rt click on the desktop, select Createnew->File->Link to application, select 'application' type in name of executable (I just used 'kcontrol' as a test) & close. Icon is still the default gear but click it & up pops control center.
For mc you have to go to advanced options & select 'run in terminal'.
Mozilla worked also.
All of the links were owned by user knoppix.

10-30-2004, 05:02 AM
You could also try making a symbolic link on the desktop

cp -s /usr/bin/program /home/user/desktop/program-shourtcut