View Full Version : How to optimize my Hard Drive under Knoppix?

10-29-2004, 03:22 PM
I am a neophyte to Linux who recently successfully did a hard drive install of Knoppix 3.4 on my old computer after wiping off all evidence of Windows. Now I am trying to optimize my hard drives. As root, I can successfully execute commands like “hdparm –X66 –d1 –u1 –m16 –c3 /dev/hda”, but of course they are gone when I reboot. I have tried appending that line to /etc/init.d/bootmisc.sh" and rebooting, but this was unsuccessful in that the hard drive settings were still unchanged.

This all may be related to the fact that I had to initially install Knoppix using the cheatcode “nodma” because my CD ROM doesn’t support DMA. So now as it boots up I get a message something like “Skipping DMA acceleration as requested by command boot line.” Any suggestions on how to proceed to get my hard drives automatically optimized will be greatly appreciated. Thank you.

10-29-2004, 11:20 PM
You could try:
1) create a script and place it in /etc/init.d and create a symlink to that script using : update-rc.d scriptname defaults
2) add your line in /etc/sysconfig/harddisks. Create one if it isn't there.

:D :D

10-30-2004, 03:18 AM
If you want to remove the 'nodma' startup code, just remove it from the append line in /etc/lilo.conf & rerun lilo.

10-30-2004, 04:59 PM
Removing the "nodma" command seems to be all it took. Now it is working much better. Thank you. :)

10-31-2004, 05:15 PM

I have a similar, but in reverse, problem as in your case. I have found that the nodma cheatcode, either in the Live CD, or after I installed v3.4 onto my hard drive, the append= line... I have been using the experimental 2.6.6 kernel, though...

I have two hard drives, a CD-RW, and a DVD device, as peripherals - my second hard drive is the concern, it cant handle DMA, whereas, all the other devices, can... The nodma has never worked, and I had to resolve the issue by adding hdparm commands for all the devices into the bottom of my bootmisc.sh file - to ensure that dma is being set to what I need... i.e. hdparm commands for "setting" dma on all devices, except the second hard drive, and then a hdparm command for disabling the dma on the second hard drive.

From what I can tell, with the 2.6.6 kernel, some cheatcodes, or the append= codes, dont have any effect, while certain ones do. Appears that "tweaking" your system with the 2.6.6 kernel, is not as important as it was in previous releases, I guess, evident by the inability to alter options on the boot, as in previous. Or, these options were added so quickly into the 2.6.6 kernel, that "back-end" code was not inculded to use them yet, I dont know...

Oh well, glad you got it working :D