View Full Version : Yet ANOTHER HDD install problem

11-04-2004, 02:19 PM
Firstly, I'm new to linux in general, but so far have been trying Mandrake out and now want to dual boot it with Knoppix 3.6. I'm trying to install it onto a separate HDD, so losing any information is not a problem.

I have had a look through this forum and was unable to find this problem, but if i missed it i really am very sorry and you can feel free to point me in that direction.

Here is what happens: I boot into knoppix and then ctrl+alt+F1 to get into the terminal (?, not sure what its actually called), I then type su to get root (I've also tried without that, which makes no difference) and then type knoppix-installer. Once it comes up and I do my configuration step I click on Install and after saying Yes to the warning screen it then gives me this error:

Error: Formatting of failed. Some messages from mkfs.ext3: Useage: mkfs.ext3 [-c:-t:-] [-b block-size] [-f fragment-size] [-i bytes-per-inode] [-j] [-J journal-options] [-N number-of-inodes]

If I click on partition HDD in knoppix-installer it tells me it cannot open the hdd, i do not have read/write permission. I have tried installing it with the HDD as one large etx3 partition, and also with a 3gig/150meg/rest of drive config, and that does not work.

What am I doing wrong :( I have tried on a separate computer and get exactly the same error. Perhaps I am missing something simple? I really am a TOTAL linux noob.

11-04-2004, 06:35 PM
Hey Droid, Read this:


Also is the HD you're trying to install to IDE? e.g slave drive on the 1st IDE channel?

After you read the above guide to installation check out qtparted for partitioning your drive. Good luck

If you continue to have problems give us as much information about your hardware as you can.

11-08-2004, 08:09 AM
Thanks for that :) the sudo knoppix-installer command worked perfectly :), I wonder why none of the others did.

Cheers again :)