View Full Version : Bootmanager for Win98 (hda1) Knoppix(hda8) WinXP(hda10)

11-07-2004, 03:17 PM
Sorry if someone already suggested a solution for this. I did not find one up to now.
I want to install a bootloader to mbr of my only primary partiton of the only harddisk of my PC.
I need to boot three OS:
1. On the primary partiton (/dev/hda1) i have Win98.
2. On the the exteded partiton (/dev/hda8) there is a knoppix hd install that is not bootable in the moment.
3. Ont the extended partiton i have freed a partion and installed WinXp into it, creating a NTFS file system (/dev/hda10)
/dev/hda9 is the swap partiton, /dev/hda5 to /dev/hda7 are fat32 partitons

In the moment there is the Windows bootmanager in the MBR of /dev/hda1 that can load Win98 and WinXP.
I would like to be able to boot all three OS from the bootloader. How to add Knoppix HD install to Windows bootloader or install a bootloader able to load all three OSs. Lilo or grub? I have already worked with lilo.conf, so i am not afraid of some config file hacking.


11-07-2004, 03:28 PM
yes you could use the XP bootloader.
to do that you let the XP bootloader and lilo work together.
for me this works well.
quick sketch what i do, write LILO to a floppy, make a "image" of the floppy-mbr put that image in XP's C:\ and edit BOOT.INI mine looks like this.

[boot loader]
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOW S
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Home Edition" /fastdetect

a few more details.

1) make lilo write to floppy, have this line in lilo.conf:


or give floppy as an argument to lilo

lilo -b /dev/fd0

2) make a image of the floppy-mbr: and put it in C:\

dd if=/dev/fd0 of=/mnt/C/linux.ipl bs=512 count=1

3) Modifiy c:\boot.ini -- add a line with:


repeat 1) and 2) every time you run LILO, rename the old linux.ipl first. good to have just in case something breaks.
you can now have several linuxes booted withthat same lilo if you wish. or even win98 and XP.
happy booting

11-07-2004, 03:46 PM
I have found this tip by suse linux distribution:http://portal.suse.com/sdb/en/1996/12/nt.html
They suggest to install lilo not MBR but into the linux partition, only thing i do not get is weather it has to be a primary partiton or not. First they say to create a FAT32 data partiton (-> indicates logic partition IMHO) but in the lilo conf it torned into a primary, or the declaration of /dev/sdax partition differes from that for /dev/hdax, where x = 1 to 4 indicates the four primary partitions.
So will it work to:
1. Boot with Linux live CD, the very same that was used for the HD install
2. Mount /dev/hda8 (existing linux partition) and config lilo.conf like suggested by suse. In my case it would be

# LILO configuration file
# Start LILO global Section
boot=/dev/hda8 # where LILO should be installed
backup=/boot/boot.sda3.970428 # Backup of the previous boot sector
timeout=100 # wait at prompt: 10 s
vga = normal # force sane state
# End LILO global section
# Linux bootable partition config begins
image = /vmlinuz # default image to boot
root = /dev/hda8 # root partition is here
label = Linux
# Linux bootable partition config ends
# Name other Linux kernel images here:
# ...

But this is no good, as /dev/hda8 is most propably behind the 1024 cylinder limitation (/dev/hda1 and /dev/hda5 to 7 have about 60 GB data).

Is it possible with Grub, or Grub boot disk/boot usb stick etc?


11-07-2004, 03:51 PM
Thanks for the fast reply OErjan.
I will try it your way, did not read your suggestin before i submitted my second post.
I will give it a try right away.
/me looking around for his knoppix boot floppy or knoppix cd to access the lilo.conf and /sbin/lilo on /dev/hda8


11-07-2004, 03:59 PM
that limitation was dealt with several years ago. i have my /boot some 80G from begining of drive. works great for me.

11-07-2004, 05:09 PM
In the moment i am stuck as my bootflopy became unreadable, and even after booting the very same knoppix that was used for the hdinstall, I still am unable to create a bootfloppy, as lilo tryes to write some (intermediat?) data to /boot. But as /boot is on the cd, it fails - file system only readable.
Using the mounted /mnt/hda8/sbin/lilo results in the same error.
Wasn't there a way to copy the linux kernel directly to the flopy (with dd) and swith the root system?

EDIT: With copying my kernel to a disk (with dd) and using the rdev command to change the root file system I finally succeeded in booting into my linux installation onece more. The rest was easy, thanks to your good description. I am already writing this mail under linux started by the means of the Windows bootloader.
Thank you very much for your help