View Full Version : knoppinx-installer not working properly

11-10-2004, 07:17 AM
Dowloaded and did a PM(I think, copied KNOPPIX image and kenrel and initrd from the iso and booted with GRUB) install of knoppix 3.6 today and everything is fine (except xine not playing dvd's).

Ran knoppix-installer both with 'sdo' and from 'su' with no difference.Without IGNORE_CHECK=1 it says requirments are'nt met and starts QTparted.With it, when I try to configure it only detecs one of my two ext3 partitions(all I have on my HD).

It's on ym fairly old system
Duron 750
Asus A7v
128MB ram
28 gig IDE HD
sony 10x dvd drive
generic dvd drive that only reads cd's
Realtek 10Mb LAN card
creative Sblive value
Asus radeon first generation 32mb

Thank you for any help :)

11-11-2004, 04:18 AM
ctl alt F2. TNow you have 2 exthen passwd to set a new password.

You need a swap partition. That is why your reqs aren't met. Now you have 2 ext3 partitions. Use about 500 MB for a swap from one of them.

11-11-2004, 07:21 AM
I made another(ext3)partition and for some reason it detected it and all went well.Edited the config file to use grub and from the installer to install it to the mbr.All went well untill I rebooted and grub gives error 17.My FC1 install was lost too(the hda1 was damaged somehow) so now I have the debian type install on one partition and primary doing XP :(

After re-installing FC1 I tried to chainload the partition with knoppix but just said it doesnt recognise the command.Tried making an entry for the partition in the device map but that prety much killed grub(just said grub on boot and did othing else).

So now I'm stuck with XP :( is there anyway I can boot the partition from XP?Thanks you again for any help


installed FC1 and trying to boot the partition.All works but says it now giiving "root=/dev/hda3" but it mounts the partition(which ext3) as read-only ext2.The first time I ran it it madea hardware config which I guess didnt go well from all the "read only" messages.Now there's a bunch of them and after it says "enetering runlevel 5" it just stops.No shell, no reboot, no messages, no nothing.

Again thank you for any help

11-13-2004, 05:36 PM
Nowhere in all the documentation for 3.6 does it mention that 'knoppix-installer' works ONLY if the command line working directory is the directory that contains ' knoppix-installer '(/usr/sbin) or if it is included in the command itself.

Try---- sudo /usr/sbin/knoppix-installer