View Full Version : Still unable to install to HD

11-11-2004, 07:33 PM
Now everytime i get to Qtparted is says device not found i'm assuming its not seeing my HD. Starting to think Linux ain't for me. Its a new system I have no other operating system installed. I do believe the HD is SATA.

11-12-2004, 05:31 AM
Don't give up hope. Maybe the link (below) will help, also what version of knoppix are you trying to install?


11-12-2004, 06:07 PM
3.6 is what I've been trying to install. Redhat installs and runs just don't like it as much as knoppix. I already purchased SUSE and REDHAT for this dell server and i don't like REDHAT. SUSE doesn't see my nic card I can see why Bill Gates has what he does. I've not been able to load any extra programs like eggdrops or nothing. If i had any hair I'd have pulled it all out by now. If I had a temper I'd have beat this DELL already.

11-12-2004, 11:47 PM
Bubba, Take it one step at a time and it is doable. Knoppix has great hardware recogniztion, but sata drives are relatively new. Have you gone to that link (provided previously) and read over the how-to?

11-13-2004, 05:10 PM
I also had a problem installing 3.6 whereas there was no problem with 3.3.

The command recommended in documentation for installing 3.6 to a HD is
' knoppix-installer ' but nowhere in the all the documentation is it mentioned that it depends on what directory is active in the command line.

Just on a suspicion, I did a
' whereis knoppix-installer '
and it came back with ' /usr/sbin/knoppix-installer ' .
So, I ran this command:

sudo /usr/sbin/knoppix-installer

and there it was----the Installation Wizard that lets you set up the partitioning and installation.
knoppix 3.6 now works beautifully, thank you.

I'm wondering if perhaps some issues of the KNOPPIX 3.6 Cds default to a different location for the knoppix-installer.

11-13-2004, 06:21 PM
A good distro is Kanotix. I believe it's a step up from knoppix and includes alot more. I run Kanotix BH8 and love the way it works.

11-13-2004, 07:19 PM
I did go to the site, changed bios but it is a SATA controller it didn't see the HD once i attempted to change the bios. I will keep trying just getting frustrated. Redhat does load and works just not liking it as good as knoppix.

11-13-2004, 08:48 PM
Hey Bubba, I can understand the aggravation-I've been there too.
Just a thought maybe you want to wait for knoppix 3.8 which maybe be out soon (?)
That version could have better sata support.

11-13-2004, 08:59 PM
Kanotix is installing at this moment, thank you. It saw the HD now to work my way through the install. Sucks being a newbie.

11-13-2004, 09:13 PM
Ok kanotix was able to install to HD but does not support my nic card it seems. I'm so close to giving up.

11-13-2004, 09:52 PM
Out away from the hyped convience of windows things are sometimes more difficult, but then there's that freedom thing.
It is hard to start anew learning from a place of little knowledge. But you started like everyone else in linux because you weren't satisfied with mere convience.
I hope you don't quit and I know for myself that after awhile I realized that no matter how difficult things sometimes were there was no going back. Maybe BG & the gov will eventually get us all to go back? :)
Have you looked at the forum at www.linuxquestions.com ? They have a larger user base than this site and there are a great deal of posts on sata drive problems.


The big commercial software Corporation will take your $ and provide you with dependence.
This here isn't about profits. So I might be just pissing you off with my idealism yet you are here at a user forum telling us you want to give up. Don't give up but if you do know that you are saying Gates & $$ wins for you.
When I was starting out someone that helped me had this tag line for a signature (it always made me laugh even when I didn't want to) "The trick is not minding that it hurts"

11-14-2004, 12:51 AM
i'm not gonna give up..it just sux its not so easy to load..i bought a box to play with..just upset cause i bought SUSE and it didnt' see nic now Redhat and their website for updates suck...i didn't join here to give up..linux is just new to me

11-14-2004, 01:32 AM
So.... How much does a NIC card cost...

Harry Kuhman
11-14-2004, 02:02 AM
So.... How much does a NIC card cost...

Generaly under $10 for a 10/100, The gigabit ones go for $10-20. Occasionally can be seen for free after rebate, but if you need one now you should be able to find them in local retailers for $5 to $10, maybe less mail order but then shipping will get you unless you are buying more than just one or two cards.

11-14-2004, 10:59 AM
Knoppix cannot see sata hard drive when you use kernel 2.4.x because it isn't supported....but if you try install using kernel 2.6.x I believed it is supported. You able to install kanotix because by default, kanotix boot to kernel 2.6.x, unlike knoppix which boot to kernel 2.4.x.
Anyway what is the model of your nic?
:D :D

11-14-2004, 05:37 PM
Thank you all for your help, you all are very nice people. The nic card is a broadcom and its intregated into the MB i'm sure. Everytime I've tried and load knoppix with knoppix26 it hangs up if its not one thing its another why would kanotix be able to load with 2.6 and not knoppix.

11-15-2004, 02:24 AM
Is it correct that you couldn't change your bios for sata support?


The above link has a short how-to for getting sata recognized. The poster is using libranet but that like knoppix is a debian based distro.

It may not be of much help but it might be worth a gamble.

Keep us posted.

11-15-2004, 04:36 AM
why would kanotix be able to load with 2.6 and not knoppix.
Knoppix able to boot to kernel 2.6.x but you need to assign a cheatcode:
Knoppix ussually comes with two kernel(2.4.x and 2.6.x) and kanotix comes with single kernel(2.6.x).
Kanotix kernel are different from knoppix...........they are are using different patch.
For your broadcom nic, try download and install driver from their site.

lspci give you any info about your nic card ?

Just found this link, broadcom driver for debian:

:D :D

11-15-2004, 06:44 PM
the hd controller is SATA i'm not sure what changing bios is going to do but not see my hd. the post was no help that version fo libranet did not see my hd either, it says i have no partitonable drives.

11-15-2004, 11:01 PM
Bubba, Sorry I've been leading you up blind alleys. I thought since you wanted knoppix in the first place-and I assume it recognizes your nic that all would be well if we could get knoppix installed. Do you still have kanotix running? Do dmesg at a terminal (shell) and post the output. Also maybe lspci -v and the output from that. (You could also do this from a live cd) Perhaps someone here will have an idea what's going on. Somewhere I saw a post that someone had sata recognized on knoppix 3.3 but not 3.4 I don't know why this is such a problem.

11-16-2004, 12:54 AM
I know you are and i really appreciate it. The only things i can get online with are Redhat or knoppix but unable to install knoppix using 2.4 kernal and using 2.6 kernal it still starts to load then locks up. And i type in knoppix26 it just gets to one point and stops. I can't paste with the other kanotix because i can't get online with it. I head back offshore tonight i'll catch ya all in a week.