View Full Version : A Story of A Sad newbie

11-16-2004, 05:59 PM
I have been posting for many days now in many different forums, so I decided to put everything in one place: Starting with the beginning.
PART I: Curiosity Killed the HD
It all started when I wanted to install some Window Decorations to KDE, but I found out that i needed to install knoppix to the HD first. I found the script for the installer for Knoppix 3.6 [sudo knoppix-installer or knoppix-installer]. I ran the installer and it began the installation. First, the installer warned me that I had not "fufilled" all the requirements yet for the installer to install Knoppix. I had to only do one thing: PARTITION THE HARDDRIVE. So I kept on with the installation, and it proceeded to open QT Parted. I poked around in QT, careful not to mess anything up, and after a bit of poking, I found that All I had to do was modify 2 of the four partitions my computer already had. I had on my main partition Windows and the FAT32 filesystem, and it was an old rinky-dinky Windows 98. So I, wanting to quickly start the HD install, I reformatted the main fs to ext3. And I made another partition linux-swap. And I saved- the installer proceeded to give me the same warning. I tried using the "ignore" script, but that was fruitless, and I was about to give up.
Part II: A Shy HD
So I sought help from this wonderful :D forum. I found many different solutions. Such as using different programs, using different scripts, and running in different Konsole modes, but I was determined really, to figure it out on my own. So, at this point, the HD is still writable and readable, but now Windows is gone and there is only one folder in the HD now: Lost and Found. So I went ahead and tried to resizet the partitions. QT wouldn't resize them. I changed the main filesystem back to FAT 32, but then i couldn't access the HD AT ALL!!!!!!!!!!!!!!!!!! I couldn't and still can't save to or read from the HD. Not even cfdisk or fdisk can even read the HD to partition it, and QT is helpless.
Part III: Seeking a solution.
So I post today asking for some help:
1. How can i make this drive open up
2. How to partition a drive correctly
I was also looking into Kanotix, because the HD install is better, they say, but I can't even save to the HD to do that. And if i did it on a different comp, it wouldn't be able to write to the HD to install!!!!
bElow is some helpful info:

Alright, I'm sorry for being so vague before. When I type "cfdisk" in superuser mode, I get the error:
FATAL ERROR: Bad primary partition 1: Partition begins after end-of-disk.
Press any key to exit cfdisk
When I type "cfdisk" in a regular shell, it gives me the error:
FATAL ERROR: Cannot open disk drive
When I type the command df, to find more about my filesystems, I get:
Filesystem 1K-blocks Used Available Use% Mounted on
/dev/root 3471 1109 2362 32% /
/dev/scd0 716308 716308 0 100% /cdrom
/dev/cloop 1943588 1943588 0 100% /KNOPPIX
/ramdisk 145928 2244 143684 2% /ramdisk
AND when I try to use QTParted to delete and manage partitions, the program opens, but I can only do a few limited things.
Any help would be really appreciated, I am a Linux newbie who wishes to help others someday.

Fatal dialog error:
Xdialog: missing list parameters !
Xdialog v2.0.6 by Thierry Godefroy <xdialog@free.fr> (v1.0 was
written by Alfred at Cyberone Internet <alfred@cyberone.com.au>).
Xdialog home page available at: http://xdialog.free.fr.

Usage: Xdialog [<common options>] [<transient options>] <box option> ...

Common options:
--wmclass <name>
--rc-file <gtkrc filename>
--backtitle <backtitle>
--title <title>
--allow-close | --no-close
--screen-center | --under-mouse | --auto-placement
--center | --right | --left | --fill
--no-wrap | --wrap
--cr-wrap | --no-cr-wrap
--stderr | --stdout
--separator <character> | --separate-output
--buttons-style default|icon|text

Transient options:
--password (may be repeated 2 or 3 times before --2inputsbox or --3inputsbox)
--time-stamp | --date-stamp
--interval <timeout>
--item-help (if used, the {...} parameters are needed in menus/lists widgets)
--default-item <tag>
--icon <xpm filename>
--help <help>
--print <printer> (1)
--check <label>
--ok-label <label>
--cancel-label <label>
--begin <Yorg> <Xorg>

Box options:
--yesno <text> <height> <width>
--msgbox <text> <height> <width>
--infobox <text> <height> <width> [<timeout>]
--gauge <text> <height> <width> [<percent>]
--progress <text> <height> <width> [<maxdots> [[-]<msglen>]]
--inputbox <text> <height> <width> [<init>]
--2inputsbox <text> <height> <width> <label1> <init1> <label2> <init2>
--3inputsbox <text> <height> <width> <label1> <init1> <label2> <init2> <label3> <init3>
--combobox <text> <height> <width> <item1> ... <itemN>
--rangebox <text> <height> <width> <min value> <max value> [<default value>]
--2rangesbox <text> <height> <width> <label1> <min1> <max1> <def1> <label2> <min2> <max2> <def2>
--3rangesbox <text> <height> <width> <label1> <min1> <max1> <def1> ... <label3> <min3> <max3> <def3>
--spinbox <text> <height> <width> <min value> <max value> <default value> <label>
--2spinsbox <text> <height> <width> <min1> <max1> <def1> <label1> <min2> <max2> <def2> <label2>
--3spinsbox <text> <height> <width> <min1> <max1> <def1> <label1> ... <min3> <max3> <def3> <label3>
--textbox <file> <height> <width>
--editbox <file> <height> <width>
--tailbox <file> <height> <width>
--logbox <file> <height> <width>
--menubox <text> <height> <width> <menu height> <tag1> <item1> {<help1>}...
--checklist <text> <height> <width> <list height> <tag1> <item1> <status1> {<help1>}...
--radiolist <text> <height> <width> <list height> <tag1> <item1> <status1> {<help1>}...
--buildlist <text> <height> <width> <list height> <tag1> <item1> <status1> {<help1>}...
--treeview <text> <height> <width> <list height> <tag1> <item1> <status1> <item_depth1> {<help1>}...
--fselect <file> <height> <width>
--dselect <directory> <height> <width>
--calendar <text> <height> <width> <day> <month> <year>
--timebox <text> <height> <width>

Special options:
--version (prints version number to stderr and exits).
--print-version (same as above in a cdialog-compatible way).
--print-maxsize (prints maximum menu size in characters and exits).

Note that <height> and <width> are in characters and may be replaced by a single
XSIZExYSIZE[+/-XORG+/-YORG] parameter (like the one passed in the -geometry option
of X) which will represent the size of the Xdialog window in pixels. Specifying
a size of 0 0 (or 0x0) will auto-size Xdialog, while a size of -1 -1 (or -1x-1)
will maximize it.

(1) This Xdialog binary compiled with: lpr -P<printer> /tmp/Xdialog.tmp
as the print command. If <printer> is "" (an empty string), the -P
option is not used.
Please, please please help!!!!!![/code]

11-16-2004, 06:24 PM
You have cross posted this problem in several places, the moderators are going to be all over you.
However, this post has the most information, so I will respond here.

Try Linux fdisk. It should be able to straighten out your partitions. It doesn't have 'error checking' to prevent overlapping partitions so the safest way is to allow a bit of dead space between partitions. QTparted can fill these in later. QT parted can correctly fill partitions to eliminate dead space but it can't cope with existing overlaps.

11-16-2004, 07:51 PM
Personally, I would nuke that screwed up partition table completely and start again.

11-18-2004, 12:46 AM
It seems that my only option is to "zero" the harddrive. I have seen another post with instructions on how to do this. http://www.knoppix.net/forum/viewtopic.php?t=12999 . Zeroing is my only option, I believe, because I have changed file formats many times and screwed my hd over. So here I go. Will post later w/ results.[/url]

11-19-2004, 01:11 AM
Finally!!! I've gotten the Harddrive to work!!! I "Zeroed" it using the cat code thingy i found on a different post, and it worked. I didn't need any data on that Hd anyway, now I can start fresh, but i think im gonna use Kanotix for the HD install instead. Thanks mzilikazi!