View Full Version : X Server crashes after using pivot_root on another compu

11-28-2004, 10:03 AM

I downloaded knoppix 3.6 and installed it into a (non-bootable) external USB-HDD as a Debian Distribution with Hardware Auto detection. I then booted into the cd in single user mode and used the "pivot_root" command to transfer to the Hard Drive as detailed in the how-to at

Everything worked fine and I thought I had a fully operational Mobile Debian installation. I used apt-get to update all packages and installed some new ones and everything was okay across several reboots. However, when I connected my HD to another machine and tried to do pivot_root from it's CD-ROM drive, disaster struck. The CD booted correctly and dropped me into a shell. The pivot_root command worked and everything, but the minute I switched to runlevel 5, my X Server Crashed, claiming that the config of xf86Config file was wrong. Apparently, the X server config from my original machine persisted in the HD!!!

I have included the log file below. Is this supposed to happen? Why is it that all the other hardware parameters did not stay persistent (as is required for a mobile HD installation that will be connected to different computers) and were autodetected but the X-Server config was not? How do I make sure that the X-Server and display manager are automatically configged in all computers to which I connect the HD (Bear in mind that the knoppix cd itself boots fine all the way to X, so detection is not the problem)>

If I have to manually config X each time I put it in a different machine, then is there a good non-graphical tool in Debian that I can use?

Please let me know.


Log File:

This is a pre-release version of XFree86, and is not supported in any
way. Bugs may be reported to XFree86@XFree86.Org and patches submitted
to fixes@XFree86.Org. Before reporting bugs in pre-release versions,
please check the latest version in the XFree86 CVS repository

XFree86 Version (Debian 4.3.0.dfsg.1-6 20040707142024 fabbione@fabbione.net)
Release Date: 15 August 2003
X Protocol Version 11, Revision 0, Release 6.6
Build Operating System: Linux 2.4.23 i686 [ELF]
Build Date: 07 July 2004
Before reporting problems, check http://www.XFree86.Org/
to make sure that you have the latest version.
Module Loader present
OS Kernel: Linux version 2.6.7 (root@Knoppix) (gcc-Version 3.3.4 (Debian 1:3.3.4-3)) #2 SMP Wed Jul 28 04:25:36 CEST 2004
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/XFree86.0.log", Time: Sun Nov 28 17:44:43 2004
(EE) Unable to locate/open config file
(EE) Error from xf86HandleConfigFile()

Fatal server error:
no screens found

When reporting a problem related to a server crash, please send
the full server output, not just the last messages.
This can be found in the log file "/var/log/XFree86.0.log".
Please report problems to submit@bugs.debian.org.