PDA

View Full Version : Problems after apt-get upgrade



funny1
12-11-2004, 06:13 AM
Hi,

I did an apt-get upgrade after which I am unable to do any other apt-gets. (I can however do an apt-get update). I looked at some other posts on this site on this issue and tried following the suggestions there, but am still stuck. Whenever I try and install a package it says the following package has unmet dependencies - libntfs5.

So I tried doing an install of libntfs5, it then says

dpkg- error processing /var/cache/apt/archives/libntfs5_1.9.2-2_i386.deb (--unpack)
trying to overwrite `/usr/lib/libntfs.so.5.0.0', which is also in package ntfsprogs
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Errors were encountered while processing:
/var/cache/apt/archives/libntfs5_1.9.2-2_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Following this I tried to remove the lib package in /var/cache/apt/archives and do a
'touch /usr/lib/libntfs.so.5.0.0' I have also tried to do an apt-get -f install but none of the above seem to work. I am therefore stuck and cannot download any packages. Can someone help?

Thanks.

eco2geek
12-11-2004, 06:18 AM
Try:

dpkg -r ntfsprogs (followed by)
apt-get -f install

fashions
12-28-2004, 01:14 AM
Try:

dpkg -r ntfsprogs (followed by)
apt-get -f install

having same problems,

root@i40dtp:/home/cbal# dpkg -r ntfsprogs
dpkg: dependency problems prevent removal of ntfsprogs:
ntfsprogs-dev depends on ntfsprogs (= 200309071734captive1).
dpkg: error processing ntfsprogs (--remove):
dependency problems - not removing
Errors were encountered while processing:
ntfsprogs
root@i40dtp:/home/cbal#

this didn't help.

GreyGeek
12-28-2004, 02:31 AM
Hi,

I did an apt-get upgrade after which I am unable to do any other apt-gets. (I can however do an apt-get update). I looked at some other posts on this site on this issue and tried following the suggestions there, but am still stuck. Whenever I try and install a package it says the following package has unmet dependencies - libntfs5.

So I tried doing an install of libntfs5, it then says

dpkg- error processing /var/cache/apt/archives/libntfs5_1.9.2-2_i386.deb (--unpack)
trying to overwrite `/usr/lib/libntfs.so.5.0.0', which is also in package ntfsprogs
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Errors were encountered while processing:
/var/cache/apt/archives/libntfs5_1.9.2-2_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Following this I tried to remove the lib package in /var/cache/apt/archives and do a
'touch /usr/lib/libntfs.so.5.0.0' I have also tried to do an apt-get -f install but none of the above seem to work. I am therefore stuck and cannot download any packages. Can someone help?

Thanks.

From Chapter 7 of the Apt Howto:
"If the installation breaks in the middle of the process and you find that it's no longer possbile to install or remove packages, try running these two commands:
apt-get -f install
dpkg --configure -a

and then try again. It may be necessary to run the second command more than once."

CrashedAgain
12-28-2004, 05:40 PM
apt-get -f remove <packagename> is also a valid command & may force removal of the program for you. also dpkg has a -force-overwrite option. see man dpkg.