View Full Version : Unable to mount external USB WD HD using Knoppix

12-12-2004, 02:04 AM
Hello Gurus,

I need urgent help! Here's the story -
I have a Compaq XP desktop which was working fine until last week. Now, it doesn't boot. It gives the following message:
1720-SMART hard drive detects imminent failure.
Your hard disk drive is detecting an imminent failure. To ensure no data loss, backup contents and replace this hard disk.
Attribute Failed: # 05

On trying to boot it complains about missing system files.

At first, I thought that my hard drive is fried. But then I am able to access/view all my precious data using Knoppix (using CD)!!
So, I have a following plan to recover the data (and PC):
1. Copy all the data to an external drive. (I bought one Western Digital dual-option USB 2.0 hard drive 80 GB. It is preformatted to a single FAT32 partition).
2. Restore the XP to factory default using the recovery CD.
3. Reload the data into the hard disk from the external hard drive.

I believe my hard drive is fine, just the XP (boot/system files) is corrupted. Is that true?
Nevertheless, I am stuck at the Step 1 above. As soon as I plug in the external HD, Knoppix just freezes. The same thing happens when I try to boot Knoppix with the HD plugged in.
I am really a first time Knoppix user. I looked at the forum tried options that I could understand. Here are some details (A through H) that may help you help me! :)

A) fdisk -l

Disk /dev/hda: 80.0 GB, 80026361856 bytes
240 heads, 63 sectors/track, 10337 cylinders
Units = cylinders of 15120 * 512 = 7741440 bytes

Device Boot Start End Blocks Id
/dev/hda1 * 1 9796 74057728+ 7
/dev/hda2 9797 10337 4089960 f
Win95 Ext'd (LBA)
/dev/hda5 9797 10337 4089928+ b
Win95 FAT32

B) cat /etc/fstab

proc /proc proc defaults 0 0
pts /dev/pts devpts mode=0622 0 0
/dev/fd0 /mnt/auto/floppy auto
user,noauto,exec,umask=000 0 0
/dev/cdrom /mnt/auto/cdrom auto user,noauto,exec,ro
0 0
/dev/cdrom1 /mnt/auto/cdrom1 auto
users,noauto,exec,ro 0 0
# Added by KNOPPIX
/dev/hda1 /mnt/hda1 ntfs noauto,users,exec,ro,uid=knoppix,gid=knoppix 0 0
# Added by KNOPPIX
/dev/hda5 /mnt/hda5 vfat noauto,users,exec,umask=000,uid=knoppix,gid=knoppi x 0 0

C) cat /proc/partitions
major minor #blocks name

3 0 78150744 hda
3 1 74057728 hda1
3 2 1 hda2
3 5 4089928 hda5

D) lsmod |grep usb
usb-storage 54524 0 (unused)
usbmouse 1788 0 (unused)
usbkbd 2876 0 (unused)
input 3200 0 [mousedev keybdev
usbmouse hid usbkbd]
usb-uhci 21868 0 (unused)
usbcore 57120 1 [usb-storage
usbmouse hid usbkbd usb-uhci

E) mount -t vfat /dev/hda /mnt/usbhdd
mount: wrong fs type, bad option, bad superblock on /dev/hda,
or too many mounted file systems

F) root@ttyp0[knoppix]# mount -t fat32 /dev/hda /mnt/usbhdd
mount: fs type fat32 not supported by kernel

G) root@ttyp0[knoppix]# mount -t auto /dev/hda /mnt/usbhdd
mount: you must specify the filesystem type

H) root@ttyp0[knoppix]# mount -t vfat /dev/sda /mnt/usbhdd
mount: /dev/sda is not a valid block device

FYI, I am runnig Knoppix using a CD.
Can anyone please tell me how can I achieve what I am trying to do?
Again, this is very first time I am trying to use knoppix. I may need detailed Instructions compatible to a novice.
Greatly appreciate your help!


12-13-2004, 01:33 AM
If SMART says your drive is about to fail,it is.Get another hard drive.
I've never had knoppix lockup when plugging in a usb device.
Sounds like an irq conflict.You should look through the dmesg output and
/proc/interrupts.Look through the cheatcodes on the cd and try
some of them.
To mount a usb drive try
mount /dev/sda1 /mnt/test
Compaqs have been known to have a screwed up bios.
They also use the cheapest components they can get away with.
If you can't get your usb drive to work,I suggest either backup to
another hard drive(slave) or try backing up over your lan to a
windows share on another pc.
Good Luck