PDA

View Full Version : Knoppix On A Laptop



Nthline
04-01-2003, 12:27 AM
I recently went through the pains of actually installing knoppix to my laptops hard disk. Im not a master linux user yet and so I ran into a few snags that I had the joy of working out.

I supose I should give a few stats on my laptop. It is not the latest and greatest by any means yet does what I need it to.

Laptop Panasonic Toughbook CF-47
CPU P2 366
HDD 20gig
13.3" tft screen
24x CD Rom
LS-120 SuperDisk (is floppy also)
56k Xircom modem
10/100 Zonenet PCMCIA Lan card
Yamaha sound
OS's Win 2000 and Knoppix3.2

OK now for the install. I dled Knoppix 3.2 and toasted a cd with my desktop
I then performed the normal procedures for installing knoppix onto a hd. I then logged in a root and proceded to poke around the files and get a feel for everything. That is when I ran into a few snags. I could not mount my cdrom or my floppy/ls-120. So I took a peek in the /mnt folder. What? No CDROM or FLOPPY? *sigh* Ok what do we have? well this was the ls of /mnt
hda5 hdc sda
So I went while in the /mnt folder and did the following
mkdir cdrom<enter> (for all you newbies remember no news is good news)
mkdir floppy<enter>
mkdir hda1<enter>
mkdir Win2k<enter>
then i did a ls on and verified that all my new directories were there.
then I ran a series of mount commands to besure that I could now mount all the devices and sure enough I could. The commands will look like this.

mount /dev/hda1 /mnt/Win2k

mount /dev/floppy /mnt/sda (something to note here is that Knoppix is seeing the ls-120 as a scsi device. I really dont know why other flavors pick it up as a ls-120)

mount /dev/cdrom /mnt/cdrom

Now to my fstab settings. There was a bunch of hardware found that was commented out and I vied my fstab to look as follows.

# /etc/fstab: filesystem table.
#
# filesystem mountpoint type options dump pass
/dev/hda5 / ext3 defaults,errors=remount-ro 0 1
/dev/hda6 none swap sw 0 0
proc /proc proc defaults 0 0
/dev/fd0 /floppy vfat defaults,user,noauto,showexec,umask=022 0 0
/dev/cdrom /mnt/cdrom iso9660 defaults,ro,user,noexec 0 0
# partitions found by Knoppix
/dev/hda1 /mnt/Win2k ntfs users,exec,ro,uid=knoppix,gid=knoppix 0 0
#/dev/hda5 /mnt/hda5 ext3 noauto,users,exec 0 0
/dev/sda /mnt/floppy auto noauto,users,exec 0 0
#/dev/hdc /mnt/hdc auto noauto,users,exec 0 0

now everything works and i can mount my drives. Now under the knoppix user I had to install OSS sound driver to make my sound card work and I have not yet tested the modem as I do not have a dialup account to try it on. Otherwise everything is running fine and I very happy. I hope that this post will inspire more posts of individuals installing Knoppix on to laptops.

Happy Tweaking
Nthline

MattT
04-01-2003, 02:30 AM
I am glad you got it to work. You'r better at Linux than I am. I recently had the same problem, couldn't mount cdrom. This topic explains why you probably had the problem and the easy way to fix it.
http://www.knoppix.net/forum/viewtopic.php?t=1499
:)