View Full Version : Help with HD-Install of KNOPPIX !!!

12-23-2004, 03:09 PM
Hi all,

I just burned a knoppix live CD and was booting with the CD.

I got the below message and wasnt able to boot complete with KDE .. The CD works fine in another computer.

Welcome to the KNOPPIX live Linux-on-CD!

Scanning for USB/Firewire devices... Done.
Enabling DMA acceleration for: hda [xxxxxxxxx]
Enabling DMA acceleration for: hdc [yyyyyyyyy]
Looking for CDROM in: /dev/scd0
Can't find KNOPPIX filesystem, sorry.
Dropping you to a (very limited) shell.
Press reset button to quit.

additional builtin commands avaliable:
cat mount umount
insmod rmmod lsmod


Then , i tried booting using the FAILSAFE mode ..with which i booted sucessfully . I then ran "sudo knoppix installer" ..the partition manager ran and i created partitions of a swap size of 300 MB and an EXT3 parition of 4.7GB . After this, the installation program is terminated and im back in the LInux kDE again.

I dont understand why this is happening and what are the suggested techniques i can use to install knoppix.

I had installed knoppix 3.3 in the past and it worked perfectly. the command knx-hdinstall doesnt work at root !!

My system configuration:

P II 400 Mhz, 128 MB ram , 48 X cd drive , 13gb + 9 gb Hdd's , INTEL 440 BX motherboard.
currently running windows 2000.

Any help would be appreciated.

Thanks in advance.

12-23-2004, 03:10 PM

Forgot to add that I was trying to install Knoppix 3.7 !

12-23-2004, 05:53 PM
If it will boot failsafe it probably means that it is not detecting some hardware correctly...probably your video card. Try cheatcodes to solve this.
What happens if you boot failsafe then 'startx' or 'kdm'? Does the gui start?
They is/was a bug in the knoppix installer which stops it from running from terminal; kanotix has fixed this but I don't know if kanotix-installer can be used to install knoppix. So you may have to get KDE working in order to HD install.

12-24-2004, 12:10 AM
KDE is working when i start with failsafe. i found that some users had the same problem as im facing that the cd doesnt load LINUX on normal startup

I have to start it in failsafe mode and then the installer is buggy in the failsafe mode.

any linux gurus tell me whats wrong???????


12-24-2004, 02:09 AM
Try boot with cheatcode : nodma or noscsi


Harry Kuhman
12-24-2004, 02:17 AM
Can't find KNOPPIX filesystem, sorry.
Dropping you to a (very limited) shell.
Press reset button to quit.
Sounds like you used the right technique to burn the CD.
Did you confirm the md5 checksum of the iso before you burnt it?
Did you burn at a nice reasonable speed like 4x rather than telling the CD writer to go like a bat out of hell? This error sounds very much like the CD drive is having a lot of trouble reading the CD. Is the CD drive in good shape, or have you had other problems with it? (And I do agree with shah's cheat codes, particularly nodma).

12-25-2004, 12:28 AM
what about the problem with the installer ??? when i run the command, sud knoppix-installer ,

the installer exits just after the partioning is done...

any ideas??

12-25-2004, 04:34 PM
booting with the cheat code NODMA worked !

12-25-2004, 06:38 PM
I usually have the following on my system
hda1 (windows C)
hda2 (/boot)
hda4 (extended)
hda5 (windows D)
hda6 (windows E)
hda7 (windows F)
hda8 (/)
hda9 (swap)

I do this, because in the past, lilo required to be below the 1024 cylinder boundery. Nowadays I'm using grub, which doesn't have the problem, but it is installed on the /boot partition anyways.

The ultimate advantage of ths setup is, that I set /dev/hda2 active and can use gub to boot linux or windows. If I damange my linux (like now) I can still use grub to boot windows.
If I decide (like now) to reformat /dev/hda2 and start over again, I simply set /dev/hda1 active and Windows can boot by itself again, since nothing was modified.

Now I want to install Knoppix 3.7 to the HDD and want to use:
1) GRUB insteat lilo
2) Place grub in /dev/hda2 and not in /dev/hda8 like the installer does it.

I manually changed the config file before I did the install. But for option (2) I don't have any glue that doing it per hand myself, when the install is finished.

Sincerly, Art

12-31-2004, 10:44 PM
can anybody answer my question ?
the install quits after i do the partioning saying that the filesystem is larger than drive
i posted the question . got 77 views but no Replies !!!

can anyone tell me why im getting the error during installation??

my partions are clean on my hdd..


01-01-2005, 03:33 AM
Try delete all partition created by qtparted especially the linux partition.
Recreate the partition from within windows using any partition manager, ex: partition magic.
Boot from cd, unmount linux partition to where you want to install and run the installer.
How to install to multi partition: