PDA

View Full Version : Can't Get Hard Drive to Mount When Booting Up



glidetothehoop
12-24-2004, 12:18 AM
I installed Knoppix to my HD using the option that allows multiple users, but is not the full-blown debian. Things are working pretty well except I can't get the partition HDB1 to mount when booting up. the contents of my fstab file is shown below. I'm not even sure what some of the entries are since I'm faiirly new to linux.

I have tried to edit the fstab manaually and I also tried to use Webmin edit the system so the HDB1 would be mounted automatically. Any suggestions would be appreciated. The drive will mount manually after I'm into KDE.

Here's my fstab file....

------------------------------------- beginning of file
# /etc/fstab: filesystem table.
#
# filesystem mountpoint type options dump pass
/dev/hda1 / ext3 defaults,errors=remount-ro 0 1
/dev/hdb1 /mnt/hdb1 etc defaults 0 0


proc /proc proc defaults 0 0
/dev/fd0 /floppy vfat defaults,user,noauto,showexec,umask=022 0 0
usbdevfs /proc/bus/usb usbdevfs defaults 0 0
sysfs /sys sysfs defaults 0 0
/dev/cdrom /cdrom iso9660 defaults,ro,user,noexec,noauto 0 0
/dev/cdrom1 /cdrom1 iso9660 defaults,ro,user,noexec,noauto 0 0
/dev/dvd /dvd iso9660 defaults,ro,user,noexec,noauto 0 0
/dev/cdaudio /cdaudio iso9660 defaults,ro,user,noexec,noauto 0 0
/dev/cdrom1 /mnt/auto/cdrom1 auto users,noauto,exec,ro 0 0

# Added by KNOPPIX
/dev/hda2 none swap defaults 0 0

------------------ end of file contents

Thanks in advance!

shah
12-24-2004, 01:05 AM
/dev/hdb1 /mnt/hdb1 etc defaults 0 0

And your hdb1 partition type?Is it vfat, ntfs, ext2, ext3......etc?
Check with : fdisk -l
Try put it at the bottom of yout fstab and add "auto" in that line.

EX. if hdb1 is a vfat partition:

------------------------------------- beginning of file
# /etc/fstab: filesystem table.
#
# filesystem mountpoint type options dump pass
/dev/hda1 / ext3 defaults,errors=remount-ro 0 1

proc /proc proc defaults 0 0
/dev/fd0 /floppy vfat defaults,user,noauto,showexec,umask=022 0 0
usbdevfs /proc/bus/usb usbdevfs defaults 0 0
sysfs /sys sysfs defaults 0 0
/dev/cdrom /cdrom iso9660 defaults,ro,user,noexec,noauto 0 0
/dev/cdrom1 /cdrom1 iso9660 defaults,ro,user,noexec,noauto 0 0
/dev/dvd /dvd iso9660 defaults,ro,user,noexec,noauto 0 0
/dev/cdaudio /cdaudio iso9660 defaults,ro,user,noexec,noauto 0 0
/dev/cdrom1 /mnt/auto/cdrom1 auto users,noauto,exec,ro 0 0

# Added by KNOPPIX
/dev/hda2 none swap defaults 0 0
/dev/hdb1 /mnt/hdb1 vfat auto users,exec,umask=000,quiet 0 0

------------------ end of file contents

:D

glidetothehoop
12-24-2004, 01:41 PM
Thanks for the help all! My files system is EXT3 and was not correctly identified as such in the fstab file.

Also, I did add the AUTO option. With those two changes HDB1 partion mounts perfectly at bootup!

Thanks Again!