PDA

View Full Version : HOW TO EDIT GRUB TO BOOT KNOPPIX 3.6..PLEASE HELP



Drool King
12-30-2004, 03:28 AM
Hiyall!,

Could someome please help me on editing my GRUB? I have WinXP (hd0) and Knoppix3.6 (hd1,0) and Fedora Core 3 (hd1,1). I was using WinXP and Knoppix first and it was using the LILO bootloader. When I installed FC3 it overwrote the LILO and used GRUB as its default bootloader.

I can't boot my Knoppix now because the command in the GRUB is the same as the one for WinXP (root verify, chainloader +1). I neec your help because I still want to use my Knoppix 3.6. Please Help!!

DK :oops:

shah
12-30-2004, 05:37 AM
Try this:
example:

title Knoppix
root (hd1,0)
kernel /boot/vmlinuz-2.6.6 root=/dev/hdb1 ro ramdisk_size=100000 lang=us apm=power-off hda=scsi hdb=scsi hdc=scsi hdd=scsi hde=scsi hdf=scsi hdg=scsi hdh=scsi nomce vga=791
initrd=/boot/initrd.img-2.6.6

** change /boot/vmlinuz-2.6.6 and initrd=/boot/initrd.img-2.6.6 to the kernel image you want to use(check in /boot).

:D

Drool King
12-31-2004, 03:56 AM
Shah,

Thanks very much! It worked! Problem now is that the mouse is not working (but it is working when I use the knoppix CD and when I boot expert26). Could you please help on what settings I need to change? Thanks again.

DK :wink:

shah
12-31-2004, 07:57 AM
Sometime the mouse doesn't work on certain kernel version. Check if it work on kernel 2.4.

Edit /etc/X11/XF86Config-4 and add this lines:

Section "InputDevice"
Identifier "Serial Mouse"
Driver "mouse"
Option "Protocol" "Microsoft"
Option "Device" "/dev/ttyS0"
Option "Emulate3Buttons" "true"
Option "Emulate3Timeout" "70"
Option "SendCoreEvents" "true"
EndSection

Section "InputDevice"
Identifier "PS/2 Mouse"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "ZAxisMapping" "4 5"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "true"
Option "Emulate3Timeout" "70"
Option "SendCoreEvents" "true"
EndSection

Section "InputDevice"
Identifier "USB Mouse"
Driver "mouse"
Option "Device" "/dev/input/mice"
Option "SendCoreEvents" "true"
Option "Protocol" "IMPS/2"
Option "ZAxisMapping" "4 5"
Option "Buttons" "5"
EndSection

If that doesn't work, boot using cd.... and copy /etc/X11/XF86Config-4 from ram to hdd and replace.
:D :D