PDA

View Full Version : HDD Install gone bad



bonkas
01-01-2005, 01:23 AM
Ok I installed knoppix to my hard drive..

everything is ok untill I try to boot up I get this error

hda: dma_intr: status=0x51 {DriveReady SeekComplete Error }
hda: dma_intr: error=0x84 { DriveStatusError BadCRC }
hda: dma_intr: status=0x51 {DriveReady SeekComplete Error }
hda: dma_intr: error=0x84 { DriveStatusError BadCRC }
hda: dma_intr: status=0x51 {DriveReady SeekComplete Error }
hda: dma_intr: error=0x84 { DriveStatusError BadCRC }
hda: dma_intr: status=0x51 {DriveReady SeekComplete Error }
hda: dma_intr: error=0x84 { DriveStatusError BadCRC }

I read on another thread it's because I need to remove A line from the bootmisc.sh file so I booted from the CD and attempted to change this file but it is read only and I cannot change any of the file permissions or anything.. I right clicked the drive and chose change read/write status or something and made the drive writable but it didnt seem to do anything.

So i right clicked the drive again and changed file permissions there to all read/write but that didnt work either...

I tried these commands from another thread

sudo mount /dev/hd?? /mnt/hd??
sudo favorite_editor /mnt/hd??/etc/init.d/bootmisc.sh

But I get the message saying the drive is busy or something.

Also when I boot from the hard drive I notice the drive is mounted as read only there also..

I hope you guys can help

shah
01-01-2005, 02:03 AM
I don't think you can write to your hdd with that condition.
What you can do is try check you hdd cable.
Check your hdd setting in bios, try re-dectect it again.
Try use different version of kernel.
Check/test memory.
Check for bad sector.
Reformat.
Zero out your hdd : dd if=/dev/zero of=/dev/hda bs=512 count=1000

Good luck
:D

Markus
01-01-2005, 10:27 AM
sudo mount /dev/hd?? /mnt/hd??
sudo favorite_editor /mnt/hd??/etc/init.d/bootmisc.sh Try instead:
Boot knoppixCD with the nodma cheatcode
Open a console
sudo su
mount -o remount,rw /dev/hd?? /mnt/hd??
mcedit /mnt/hd??/etc/init.d/bootmisc.sh (comment out dma with a # /sbin/hdparm -qd1 /dev/hd?)
mcedit /mnt/hd??/etc/lilo.conf (add nodma to the append line)
chroot /mnt/hd??
lilo -v

If chrooting doesn't work, try:
umount /dev/hd?? /mnt/hd??
mount -o dev /dev/hd?? /mnt/hd??

bonkas
01-02-2005, 05:16 AM
Ok I boot from the CD anter the root shell...

I type sudo su and I guess it works as it goes to the next line

then I tryed "mount -o remount,rw /dev/hda1 /mnt/hda1"
and it said I must specify a filesystem

So I skipped to "umount /dev/hda1 /mnt/hda1"
And it said Not Mounted

I tryed "mount -o dev /dev/hda1 /mnt/hda1"
And it sayd Invalid option -o

I tryed "mcedit /mnt/hd??/etc/init.d/bootmisc.sh"
This command works and opens up a thingy to edit it but I go to save and i cannot save it.

I also notice the I cannot change the permissions of this file.. Howcome.. This may also be what I need to do to edit that file..

I have no idea what is going on...

Markus
01-02-2005, 09:28 AM
then I tryed "mount -o remount,rw /dev/hda1 /mnt/hda1"
and it said I must specify a filesystem What FS is it? If ext3 try:
mount -t ext3 -o remount,rw /dev/hda1 /mnt/hda1

Could you post the output of: sudo fdisk -l


So I skipped to "umount /dev/hda1 /mnt/hda1"
And it said Not Mounted

I tryed "mount -o dev /dev/hda1 /mnt/hda1"
And it sayd Invalid option -o Weird, I've never got that error.


I tryed "mcedit /mnt/hd??/etc/init.d/bootmisc.sh"
This command works and opens up a thingy to edit it but I go to save and i cannot save it.

I also notice the I cannot change the permissions of this file.. Howcome.. This may also be what I need to do to edit that file.. Possibly because it's mounted read only.
If your /etc/fstab is set up correctly when booted with liveCD and nodma cheatcode you could try just sudo mount -a to mount all partitions rw.

bonkas
01-02-2005, 10:44 PM
I am still having trouble..

I type mount -t ext2 -o remount,rw /dev/hda1 /mnt/hda1 It says...
mount: /mnt/hda1 not mounted already, or bad option

I typed sudo mount -a It says...
Mount: pts already mounted or /dev/pts busy

I Typed sudo fdisk -l I get returned...
Disk /dev/hda: 255 heads, 63 sectors, 1245 cylinders
Units = cylinders of 16065 * 512 bytes

Device Boot Start End Blocks ID System
/dev/hda1 * 1 1186 9526513+ 83 Linux
/dev/hda2 1187 1245 473917+ 82 Linux Swap

I am really confused here.. Do you have MSN, Yahoo or mIRC or something that I can talk to you on?

bonkas
01-03-2005, 05:35 AM
Well I tried reindtalling using a different install method and now I am getting alot of errors during install and it hanging at 89% If I cant get all this fixed within an hour I am going back to Microshit Windows.

But if you do have MSN, Yahoo or another way I can speak to you I would like to get all this sorted.

Markus
01-03-2005, 02:15 PM
The install errors look like it would be a bad burn http://www.knoppix.net/wiki/Downloading_FAQ
- try booting with the testcd cheatcode http://www.knoppix.net/wiki/Cheat_Codes
- check the md5sum of the iso if you still have it http://www.linuxiso.org/viewdoc.php/verifyiso.html
- burn at max x4 speed http://members.home.nl/lsnoek/iso.htm

bonkas
01-03-2005, 09:35 PM
I have burned it from the original 3 times now and also onto good quality CD's at 1x, 4x and 24x still same problems with each speed

I am on 56k so I dont want to download it all over again right now..lol

Harry Kuhman
01-03-2005, 09:50 PM
I am on 56k so I dont want to download it all over again right now..lol
Are you trying to say that you can't be bothered to check the md5 sum? If the md5 sum is right then there would be absolutely no reason to download it again, even if you wre on a high speed connection. That you made the above statement makes it sound like you didn't bother with this step, even after people went to the trouble to give you links on it.

bonkas
02-20-2005, 04:56 AM
Ok it's been a while but today I was fiddling around with a few things and was able to change the file using this command..

sudo mount /dev/hd?? /mnt/hd??
sudo favorite_editor /mnt/hd??/etc/init.d/bootmisc.sh

Now I am able to boot from hard drive fine with no problems.. well almost no problems..lol

First problem I have it that when I start up I get this error...

"/dev/hda2 has gone 49709 days without being checked, check forced"

This takes quite some time to complete and it happens everytime I boot up...

I was thinking that the problem coud be that it cant tell knoppix that it has already done the check once before because my hard drive is read only. So that leads to the next question..

How do I make my hard drive writable when the computer starts up?

And I notice I can change any file permissions or anything while logged in as knoppix user but I can change file permissions while in root user but that doesent help me since I cant change any files anyway hehe..

Hope you guys can help.

mr_ed
02-20-2005, 06:45 AM
Hey, glad you could get it going! :D


when I start up I get this error...
That's not an error, that's a feature! :wink:


How do I make my hard drive writable when the computer starts up?
$ cat /etc/fstab to see how it's set up there. If, however it happened, the line that the drive is on has ro, then that's the problem. With su or sudo or however you log in as root, delete that option.

Also check to make sure it doesn't have the noauto option. If that's there, then delete that too.

Now, next time you boot, the drive should come up read/write.

Then, still as root, type

# mount -a

to automatically mount everything in /etc/fstab that is automountable (that is, everything that doesn't have the noauto option).

Get back out of root, and the drive should now be mounted read/write for you to use without needing to reboot.

Let us know if this doesn't work.

-- Ed