PDA

View Full Version : Klik is kewl, but a few questions...



JockVSJock
01-03-2005, 03:56 PM
This is a very kewl project. Knoppix continues to blow my mind.

Was able to install the Klik client on a knoppix box that I'm using as a server. The reason I installed it is that I'm looking to install either Real Player or Kaffeine.

Reading the webpage, looks like it runs new version of Knoppix. My server is like 3.3 or 3.4, can't find a version command line. Will there be a problem in trying to install packages?

Also, I'm using apt-get to update and install packages, and only getting stable packages. I've tried to install Kaffeine, which is listed in the unstable packages, I believe. Will there be any conflicts with this and apt-get and unstable packages?

thanks

Superstoned
01-15-2005, 10:38 PM
This is a very kewl project. Knoppix continues to blow my mind.

Was able to install the Klik client on a knoppix box that I'm using as a server. The reason I installed it is that I'm looking to install either Real Player or Kaffeine.

Reading the webpage, looks like it runs new version of Knoppix. My server is like 3.3 or 3.4, can't find a version command line. Will there be a problem in trying to install packages?

Also, I'm using apt-get to update and install packages, and only getting stable packages. I've tried to install Kaffeine, which is listed in the unstable packages, I believe. Will there be any conflicts with this and apt-get and unstable packages?

thanks

you can change the 'default' repository for packages in /etc/apt/apt.conf.

if you issue a "apt-get install kaffeine", apt-get will first look in stable (if thats default, of course) if its there, if not, then testing, if not there, then unstable.

you shouldn't have any problems mixin' stable, testing and unstable.

probono
01-16-2005, 01:16 PM
Klik supports Knoppix 3.7 and up. You might be able to get some apps to run using older Knoppix versions, but I would expect problems with most apps.

As a temporary, unsupported, inofficial workaround, you can add @2004-02-09 to any klik link, then it tries to be Knoppix 3.3+ compatible, e. g. klik://xvier@2004-02-09 - but that will only install software ftom 2004-02-09.

Greetings,
probono