PDA

View Full Version : How can I get English as my HD OS default?



scruffyeagle
01-10-2005, 06:39 AM
In a nutshell:
I need to globally reset the locale & keyboard to make US English the default for virtual console sessions, and all my efforts so far have failed - so, I'm seeking help.

Here's the situation:
Every time I've tried to install Knoppix to HD using the current HD & partitioning scheme on this HP6360 Pavilion, I've failed entirely - until my most recent attempt. Previously, it would seem to do a full installation, then I'd see a series of error messages in black background on the blue screen. This current installation attempt was almost successful, via selecting the "Knoppix" style installation choice. I got past the problem that's obstructed previous attempts by choosing LILO into partition instead of MBR, and then editing the grub.conf file in the other OS's partition to make the Knoppix an available option.

Booting into this new Knoppix installation for the first time, I found it operating in German (At least, I think that's what that language is,...). I reset the language & keyboard via KDE's utilities, rebooted, and that aspect of the setup is working okay (I think). The problem, is that when I go out to a virtual console, the OS is functioning in German, instead of the U.S. English language & keyboard I need. All the system messages are in German. The default keyboard is German(?). The letters (etc.) assigned to keys are in different places than I'm used to. I don't know German, and really haven't had any intention of making a study of that language. This stuff makes it very difficult to work with.

I tried using "dpkg-reconfigure locales". It allows selection & generation of locales okay, and exits without apparent error, but the default language doesn't get reset to fit what I tell it. (I did this twice, and it wouldn't work either time.)

A few special notes for other relative newbies who might attempt this: The first time I tried this, I wiped out the German locale being an option, thinking there'd be no problem having the US locale set as default. It didn't work - and, then "dkpg-reconfigure locales" wouldn't work either (it couldn't find the locale data of it's registered language default). To make it functional again, I had to edit "/etc/locale.gen" to uncomment (remove the #) from beginning of the "de_DE@euro ISO-8859-15" line, and save it that way. Editing required using "-v" as parameter onto the "vi" command to escape working in "vim" mode (vi isn't there - trying to use it activates vim.); i.e., the command was "vi -v locale.gen". After saving the file, I had to run "locale-gen", which scanned the "locale.gen" file, and used what it found to selectively re-create locale data.

I suspect the default OS language & keyboard could be reset via manually editing several files in the "/etc/sysconfig" directory, but I don't know that for a fact, which makes me hesitant to attempt it. After all - this is the first installation attempt in about 5, that's actually worked well enough to allow booting into a Knoppix session. I'd hate to screw it up by reckless editing - the procedure for creating a boot floppy during installation didn't work; I tested the boot floppy it made, and the computer crashes with an "Operating System not found" message. So, there's no fallback option, if I make this installation unbootable.

I'd like the locale to be set as "en_US ISO-8859-1". I'd like the keyboard to be set suitable for a "Microsoft Internet Keyboard"; i.e., a 104-key w/ logo keys.

Is anybody out there capable of telling me exactly which files I need to edit to make the language & keyboard changes happen, and exactly what new data I need to enter into each of those various files?

Thanks in advance, for any help you can give me re. this.

Scruffy
http://scruffyeagle.com

rrfish72
01-10-2005, 07:27 AM
Edit lilo.conf and add lang=us (or change to) in the append line.

scruffyeagle
01-12-2005, 03:52 AM
Edit lilo.conf and add lang=us (or change to) in the append line.

Yah, hey dere!

Thanks for the reply. I'm not using the LILO from the installation process, because I'd had several installation attempts flop before this attempt. I made Knoppix put the LILO into partition, so I could edit the grub.conf file in a Red Hat partition and continue using GRUB instead of returning to LILO. I've set the GRUB entry to use the Knoppix partition as root for the sake of this new installation, and it'll boot the kernel & initrd from the /boot directory there. Can you use "append=" statements in GRUB? I've read the GRUB documentation, but I can't remember offhand whether or not it allows such in GRUB entries. I guess I'll have to check re. this when I get back to the other machine, later,... Anyway, if it's something GRUB allows, then you just gave me the key for making it work the way I want (I think).

Thanks!

rrfish72
01-12-2005, 04:58 PM
Grub/menu.lst also has that:

title Debian GNU/Linux, kernel 2.6.8.1-kanotix-5
root (hd0,5)
kernel /boot/vmlinuz-2.6.8.1-kanotix-5 root=/dev/hda6 ro ramdisk_size=100000 lang=us apm=power-off hda=scsi hdb=scsi hdc=scsi hdd=scsi hde=scsi hdf=scsi hdg=scsi hdh=scsi nomce vga=0x317
savedefault
boot

Hope this helps.

CrashedAgain
01-12-2005, 08:42 PM
If the above doesn't work, edit /etc/init.d/knoppix-autoconfig; it default lang is specified as 'de' in this file. It should work to edit so that the default is 'us'.

scruffyeagle
01-14-2005, 03:49 AM
Grub/menu.lst also has that:

title Debian GNU/Linux, kernel 2.6.8.1-kanotix-5
root (hd0,5)
kernel /boot/vmlinuz-2.6.8.1-kanotix-5 root=/dev/hda6 ro ramdisk_size=100000 lang=us apm=power-off hda=scsi hdb=scsi hdc=scsi hdd=scsi hde=scsi hdf=scsi hdg=scsi hdh=scsi nomce vga=0x317
savedefault
boot

Hope this helps.

Hi!

Thanks for your response.

I dug into it earlier today, read up a bit, tinkered a bit, and got it working via something similar to your kernel line - except, I didn't use the "apm=power-off", and only specified the drive the booting is on ("hdg=ide-scsi"). NOTE: Apparently, the "apm=power-off" entry becomes unnecessary in HD installations, because it powered down without any apparent glitch later on, when the time came to shut down.

I included the "ramdisk_size=100000", "lang=us", "nomce", and "init=/etc/init", entries, as per the contents which autosetup put into the lilo.conf file, and used the "vga=791" from there also. I booted it, and it worked! From there, I created an entry for booting the v2.6.6 kernel, and an entry for booting the v2.4.26 kernel in CLI mode (tacking on "2" at the end of the kernel line in that entry).

What do the "color=red" and "/color" parameters, and "savedefault" command do?

scruffyeagle
01-14-2005, 03:59 AM
If the above doesn't work, edit /etc/init.d/knoppix-autoconfig; it default lang is specified as 'de' in this file. It should work to edit so that the default is 'us'.

Hi!

Thanks for the tip. Even though I've managed to get it to set "us" as language default via GRUB configuration's contents (adding param to kernel line), knowing where Knoppix is tucking away that bit of data seems really useful. I'll probably make use of what you've told me here - editing the knoppix-autoconfig, and thereby making use of the "lang=us" kernel line parameter unnecessary (so I can trim down that grub kernel line entry slightly).